diff mbox series

[meta-python,2/3] python3-colorama: Upgrade 0.4.5 -> 0.4.6

Message ID 20221026115124.289505-2-leon.anavi@konsulko.com
State Under Review
Headers show
Series [meta-python,1/3] python3-pythonping: Upgrade 1.1.3 -> 1.1.4 | expand

Commit Message

Leon Anavi Oct. 26, 2022, 11:51 a.m. UTC
Upgrade to release 0.4.6:

- Add alternative to 'init()', called 'just_fix_windows_console'.
  This fixes many longstanding problems with 'init', such as
  working incorrectly on modern Windows terminals, and wonkiness
  when init gets called multiple times. The intention is that it
  just makes all Windows terminals treat ANSI the same way as other
  terminals do.
- Support Windows 10's ANSI/VT console. This didn't exist when
  Colorama was created, and avoiding us causing havok there is long
  overdue.
- Internal overhaul of package metadata declaration, which
  abolishes our use of the now heavily discouraged setuptools (and
  hence setup.py, setup.cfg and MANIFEST.in), in favor of hatchling
  (and hence pyproject.toml). This includes dropping support
  Python3.5 and 3.6, which are EOL, and were already dropped from
  setuptools, so this should not affect our users.
- Attention to detail award to LqdBcnAtWork for a spelling fix in
  demo06

Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
---
 ...ython3-colorama_0.4.5.bb => python3-colorama_0.4.6.bb} | 8 ++++++--
 1 file changed, 6 insertions(+), 2 deletions(-)
 rename meta-python/recipes-devtools/python/{python3-colorama_0.4.5.bb => python3-colorama_0.4.6.bb} (56%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-colorama_0.4.5.bb b/meta-python/recipes-devtools/python/python3-colorama_0.4.6.bb
similarity index 56%
rename from meta-python/recipes-devtools/python/python3-colorama_0.4.5.bb
rename to meta-python/recipes-devtools/python/python3-colorama_0.4.6.bb
index 122ae5399..52e1e68b1 100644
--- a/meta-python/recipes-devtools/python/python3-colorama_0.4.5.bb
+++ b/meta-python/recipes-devtools/python/python3-colorama_0.4.6.bb
@@ -3,8 +3,12 @@  HOMEPAGE = "https://github.com/tartley/colorama"
 LICENSE = "BSD-2-Clause"
 LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=b4936429a56a652b84c5c01280dcaa26"
 
-inherit pypi setuptools3
+inherit pypi python_setuptools_build_meta
 
-SRC_URI[sha256sum] = "e6c6b4334fc50988a639d9b98aa429a0b57da6e17b9a44f0451f930b6967b7a4"
+SRC_URI[sha256sum] = "08695f5cb7ed6e0531a20572697297273c47b8cae5a63ffc6d6ed5c201be6e44"
+
+DEPENDS += " \
+	${PYTHON_PN}-hatchling-native \
+"
 
 BBCLASSEXTEND = "native nativesdk"