diff mbox series

[meta-python,2/2] python3-xmltodict: Upgrade 0.12.0 -> 0.13.0

Message ID 20221012130624.1336826-2-leon.anavi@konsulko.com
State Under Review
Headers show
Series [meta-python,1/2] python3-greenlet: Upgrade 1.1.3 -> 1.1.3.post0 | expand

Commit Message

Leon Anavi Oct. 12, 2022, 1:06 p.m. UTC
Upgrade to release 0.13.0:

- Add install info to readme for openSUSE
- Support defaultdict for namespace mapping
- parse(generator) is now possible
- Processing comments on parsing from xml to dict
- Add expand_iter kw to unparse to expand iterables
- Add support for python3.8
- Drop Jython/Python 2 and add Python 3.9/3.10
- Do not use len() to determine if a sequence is empty
- Add more namespace attribute tests
- Fix encoding issue in setup.py

Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
---
 ...3-xmltodict_0.12.0.bb => python3-xmltodict_0.13.0.bb} | 9 +++++++--
 1 file changed, 7 insertions(+), 2 deletions(-)
 rename meta-python/recipes-devtools/python/{python3-xmltodict_0.12.0.bb => python3-xmltodict_0.13.0.bb} (74%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-xmltodict_0.12.0.bb b/meta-python/recipes-devtools/python/python3-xmltodict_0.13.0.bb
similarity index 74%
rename from meta-python/recipes-devtools/python/python3-xmltodict_0.12.0.bb
rename to meta-python/recipes-devtools/python/python3-xmltodict_0.13.0.bb
index 1d871b2d3..aadf8b7f4 100644
--- a/meta-python/recipes-devtools/python/python3-xmltodict_0.12.0.bb
+++ b/meta-python/recipes-devtools/python/python3-xmltodict_0.13.0.bb
@@ -4,8 +4,7 @@  HOMEPAGE = "https://github.com/martinblech/xmltodict"
 LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=01441d50dc74476db58a41ac10cb9fa2"
 
-SRC_URI[md5sum] = "ddb2bd078cef4f7e3021a578034ad941"
-SRC_URI[sha256sum] = "50d8c638ed7ecb88d90561beedbf720c9b4e851a9fa6c47ebd64e99d166d8a21"
+SRC_URI[sha256sum] = "341595a488e3e01a85a9d8911d8912fd922ede5fecc4dce437eb4b6c8d037e56"
 
 PYPI_PACKAGE = "xmltodict"
 
@@ -15,6 +14,12 @@  SRC_URI += " \
 	file://run-ptest \
 "
 
+RDEPENDS:${PN} += " \
+	${PYTHON_PN}-core \
+	${PYTHON_PN}-xml \
+	${PYTHON_PN}-io \
+"
+
 RDEPENDS:${PN}-ptest += " \
 	${PYTHON_PN}-pytest \
 "