diff mbox series

[meta-python,2/2] Add python3-aiodns 3.0.0

Message ID 20220726161032.1630170-2-brenda.streiff@ni.com
State New
Headers show
Series [meta-python,1/2] Add python3-pycares 4.2.1 | expand

Commit Message

Brenda Streiff July 26, 2022, 4:10 p.m. UTC
From: Sergey Kizunov <sergey.kizunov@ni.com>

aiodns is a Python module for asynchronous DNS resolution using pycares.

Signed-off-by: Sergey Kizunov <sergey.kizunov@ni.com>

Updated and converted to new recipe syntax.

Signed-off-by: Brenda Streiff <brenda.streiff@ni.com>
---
 .../python/python3-aiodns_3.0.0.bb              | 17 +++++++++++++++++
 1 file changed, 17 insertions(+)
 create mode 100644 meta-python/recipes-devtools/python/python3-aiodns_3.0.0.bb
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-aiodns_3.0.0.bb b/meta-python/recipes-devtools/python/python3-aiodns_3.0.0.bb
new file mode 100644
index 000000000..64599d43c
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-aiodns_3.0.0.bb
@@ -0,0 +1,17 @@ 
+SUMMARY = "Simple DNS resolver for asyncio"
+DESCRIPTION = "aiodns provides a simple way for doing asynchronous DNS resolutions using pycares."
+HOMEPAGE = "https://github.com/saghul/aiodns"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=a565d8b5d06b9620968a135a2657b093"
+
+SRC_URI[md5sum] = "181e11935c78965de2b2b7b0e5efba8d"
+SRC_URI[sha256sum] = "946bdfabe743fceeeb093c8a010f5d1645f708a241be849e17edfb0e49e08cd6"
+
+PYPI_PACKAGE = "aiodns"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} += " \
+    ${PYTHON_PN}-asyncio \
+    ${PYTHON_PN}-pycares \
+"