diff mbox series

[4/8] python3-pytest-html: fix DEPENDS, don't depend on pip

Message ID 20220714124405.2037213-4-ross.burton@arm.com
State New
Headers show
Series [1/8] python3-cbor2: add missing build dependency | expand

Commit Message

Ross Burton July 14, 2022, 12:44 p.m. UTC
Add a DEPENDS on ptyhon3-setuptools-scm-git-archive-native as the setup.py
uses it.

In the future we'll have a Python building tool which validates build
requirements, so remove pip from those dependencies as it shouldn't depend
on a specific build tool being present.

Signed-off-by: Ross Burton <ross.burton@arm.com>
---
 .../python/python3-pytest-html/no-pip.patch   | 24 +++++++++++++++++++
 .../python/python3-pytest-html_3.1.1.bb       |  4 ++++
 2 files changed, 28 insertions(+)
 create mode 100644 meta-python/recipes-devtools/python/python3-pytest-html/no-pip.patch
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-pytest-html/no-pip.patch b/meta-python/recipes-devtools/python/python3-pytest-html/no-pip.patch
new file mode 100644
index 0000000000..e120498846
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pytest-html/no-pip.patch
@@ -0,0 +1,24 @@ 
+Upstream-Status: Submitted [https://github.com/pytest-dev/pytest-html/pull/516]
+Signed-off-by: Ross Burton <ross.burton@arm.com>
+
+From d7fbc79d428323c838ce68a51e1e1806c2096a76 Mon Sep 17 00:00:00 2001
+From: Ross Burton <ross.burton@arm.com>
+Date: Mon, 23 May 2022 13:46:50 +0100
+Subject: [PATCH] pip isn't a build dependency
+
+It's possible, and even desirable, to build modern Python code without pip, for example by using the `build` and `installer` packages.
+---
+ pyproject.toml | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/pyproject.toml b/pyproject.toml
+index 2683f072..e3f25bf7 100644
+--- a/pyproject.toml
++++ b/pyproject.toml
+@@ -1,6 +1,5 @@
+ [build-system]
+ requires = [
+-  "pip >= 19.3.1",
+   "setuptools >= 42",
+   "setuptools_scm[toml] >= 3.5.0",
+   "setuptools_scm_git_archive >= 1.1",
diff --git a/meta-python/recipes-devtools/python/python3-pytest-html_3.1.1.bb b/meta-python/recipes-devtools/python/python3-pytest-html_3.1.1.bb
index ce55554a01..1bbdfb633b 100644
--- a/meta-python/recipes-devtools/python/python3-pytest-html_3.1.1.bb
+++ b/meta-python/recipes-devtools/python/python3-pytest-html_3.1.1.bb
@@ -10,6 +10,10 @@  PYPI_PACKAGE = "pytest-html"
 
 inherit pypi python_setuptools_build_meta
 
+DEPENDS += "python3-setuptools-scm-git-archive-native"
+
+SRC_URI += "file://no-pip.patch"
+
 RDEPENDS:${PN} += " \
     ${PYTHON_PN}-pytest \
 "