diff mbox series

[meta-oe,1/2] nftables: Disable default python PACKAGECONFIG

Message ID 20220708205048.11990-1-alex.kiernan@gmail.com
State New
Headers show
Series [meta-oe,1/2] nftables: Disable default python PACKAGECONFIG | expand

Commit Message

Alex Kiernan July 8, 2022, 8:50 p.m. UTC
From: Alex Kiernan <alexk@zuma.ai>

The upcoming buildpaths QA check fails when python is enabled:

  WARNING: nftables-1.0.2-r0 do_package_qa: QA Issue: File /usr/lib/python3.10/site-packages/nftables/__pycache__/nftables.cpython-310.pyc in package nftables-python contains reference to TMPDIR
  File /usr/lib/python3.10/site-packages/nftables/__pycache__/__init__.cpython-310.pyc in package nftables-python contains reference to TMPDIR [buildpaths]

The way to fix it isn't at all obvious as it's not built using standard
python packaging, so disable it until someone actually needs it.
---
 meta-networking/recipes-filter/nftables/nftables_1.0.2.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/meta-networking/recipes-filter/nftables/nftables_1.0.2.bb b/meta-networking/recipes-filter/nftables/nftables_1.0.2.bb
index e078be79a1df..f1cfb4910138 100644
--- a/meta-networking/recipes-filter/nftables/nftables_1.0.2.bb
+++ b/meta-networking/recipes-filter/nftables/nftables_1.0.2.bb
@@ -18,7 +18,7 @@  SRC_URI[sha256sum] = "0b28a36ffcf4567b841de7bd3f37918b1fed27859eb48bdec51e1f7a83
 
 inherit autotools manpages pkgconfig ptest
 
-PACKAGECONFIG ??= "python readline json"
+PACKAGECONFIG ??= "readline json"
 PACKAGECONFIG[json] = "--with-json, --without-json, jansson"
 PACKAGECONFIG[manpages] = "--enable-man-doc, --disable-man-doc, asciidoc-native"
 PACKAGECONFIG[mini-gmp] = "--with-mini-gmp, --without-mini-gmp"