diff mbox series

[meta-networking] openvpn: distribute sample-config-files

Message ID 20220708155833.14750-1-alex.stewart@ni.com
State New
Headers show
Series [meta-networking] openvpn: distribute sample-config-files | expand

Commit Message

Alex Stewart July 8, 2022, 3:58 p.m. UTC
The openvpn tarball has additional sample config files which are
generally useful to users, and which are typically distributed in other
distros' openvpn packages.

Include these sample configs in the OE recipe.

Signed-off-by: Bill Pittman <bill.pittman@ni.com>

Rebased to openvpn_2.5.7.

Signed-off-by: Alex Stewart <alex.stewart@ni.com>
---
 meta-networking/recipes-support/openvpn/openvpn_2.5.7.bb | 4 ++++
 1 file changed, 4 insertions(+)
diff mbox series

Patch

diff --git a/meta-networking/recipes-support/openvpn/openvpn_2.5.7.bb b/meta-networking/recipes-support/openvpn/openvpn_2.5.7.bb
index 1395a35f5401e6a7fdc666a6711e7f27984b36b2..a28c73ab5ae978e72a9e6521738b8350f5df9dc8 100644
--- a/meta-networking/recipes-support/openvpn/openvpn_2.5.7.bb
+++ b/meta-networking/recipes-support/openvpn/openvpn_2.5.7.bb
@@ -54,8 +54,12 @@  do_install:append() {
     install -d ${D}/${sysconfdir}/openvpn/sample
     install -m 644 ${S}/sample/sample-config-files/loopback-server  ${D}${sysconfdir}/openvpn/sample/loopback-server.conf
     install -m 644 ${S}/sample/sample-config-files/loopback-client  ${D}${sysconfdir}/openvpn/sample/loopback-client.conf
+    install -dm 755 ${D}${sysconfdir}/openvpn/sample/sample-config-files
     install -dm 755 ${D}${sysconfdir}/openvpn/sample/sample-keys
+    install -dm 755 ${D}${sysconfdir}/openvpn/sample/sample-scripts
+    install -m 644 ${S}/sample/sample-config-files/* ${D}${sysconfdir}/openvpn/sample/sample-config-files
     install -m 644 ${S}/sample/sample-keys/* ${D}${sysconfdir}/openvpn/sample/sample-keys
+    install -m 644 ${S}/sample/sample-scripts/* ${D}${sysconfdir}/openvpn/sample/sample-scripts
 
     install -d -m 710 ${D}/${localstatedir}/lib/openvpn
 }