[meta-python] python3-pyconnman: Add 'future' runtime dependency

Message ID 20220616143201.347832-1-mafl@kvaser.com
State New
Headers show
Series [meta-python] python3-pyconnman: Add 'future' runtime dependency | expand

Commit Message

Marcus Flyckt June 16, 2022, 2:32 p.m. UTC
pyconnman has an install_requires on 'future', but the corresponding
'python3-future' is missing from the recipes RDEPENDS.
---
 .../python-pyconnman/python3-pyconnman_0.2.0.bb                 | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Patch

diff --git a/meta-python/recipes-connectivity/python-pyconnman/python3-pyconnman_0.2.0.bb b/meta-python/recipes-connectivity/python-pyconnman/python3-pyconnman_0.2.0.bb
index e0f3fdd75..64441065d 100644
--- a/meta-python/recipes-connectivity/python-pyconnman/python3-pyconnman_0.2.0.bb
+++ b/meta-python/recipes-connectivity/python-pyconnman/python3-pyconnman_0.2.0.bb
@@ -2,4 +2,4 @@  require python-pyconnman.inc
 
 inherit setuptools3
 
-RDEPENDS_${PN} += "python3-dbus python3-pprint"
+RDEPENDS_${PN} += "python3-dbus python3-pprint python3-future"