[meta-python,13/16] python3-eth-abi: new package

Message ID 20220512084152.1388464-14-brgl@bgdev.pl
State Under Review
Headers show
Series python: add a bunch of packages for interacting with ethereum blockchains | expand

Commit Message

Bartosz Golaszewski May 12, 2022, 8:41 a.m. UTC
Add a recipe for eth-abi: utilities for working with Ethereum ABI definitions.

Signed-off-by: Bartosz Golaszewski <brgl@bgdev.pl>
---
 .../packagegroups/packagegroup-meta-python.bb  |  1 +
 .../python/python3-eth-abi_3.0.0.bb            | 18 ++++++++++++++++++
 2 files changed, 19 insertions(+)
 create mode 100644 meta-python/recipes-devtools/python/python3-eth-abi_3.0.0.bb

Patch

diff --git a/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb b/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
index 41e30fad0..db3f8516a 100644
--- a/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
+++ b/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
@@ -110,6 +110,7 @@  RDEPENDS:packagegroup-meta-python3 = "\
     python3-email-validator \
     python3-engineio \
     python3-et-xmlfile \
+    python3-eth-abi \
     python3-eth-hash \
     python3-eth-keyfile \
     python3-eth-keys \
diff --git a/meta-python/recipes-devtools/python/python3-eth-abi_3.0.0.bb b/meta-python/recipes-devtools/python/python3-eth-abi_3.0.0.bb
new file mode 100644
index 000000000..e1f220af9
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-eth-abi_3.0.0.bb
@@ -0,0 +1,18 @@ 
+SUMMARY = "Python utilities for working with Ethereum ABI definitions, especially encoding and decoding."
+HOMEPAGE = "https://github.com/ethereum/eth-abi"
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=bf9691ead96f1163622689e47ce3f366"
+
+SRC_URI[sha256sum] = "31578b179cf9430c21ac32a4e5f401c14b6e2cc1fd64ca3587cd354068217804"
+
+PYPI_PACKAGE = "eth_abi"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} += " \
+    python3-eth-typing \
+    python3-eth-utils \
+    python3-parsimonious \
+    python3-setuptools \
+"