[meta-python,2/2] python3-marshmallow: Upgrade 3.14.1 -> 3.15.0

Message ID 20220419131354.2593158-2-leon.anavi@konsulko.com
State New
Headers show
Series [meta-python,1/2] python3-bitstruct: Upgrade 8.13.0 -> 8.14.0 | expand

Commit Message

Leon Anavi April 19, 2022, 1:13 p.m. UTC
Upgrade to release 3.15.0:

- Allow passing a dict to fields.Nested
- Address distutils deprecation warning in Python 3.10
- Add py310 to black target-version
- Drop support for Python 3.6
- Use postponed evaluation of annotations

Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
---
 ...allow_3.14.1.bb => python3-marshmallow_3.15.0.bb} | 12 ++++++++++--
 1 file changed, 10 insertions(+), 2 deletions(-)
 rename meta-python/recipes-devtools/python/{python3-marshmallow_3.14.1.bb => python3-marshmallow_3.15.0.bb} (76%)

Patch

diff --git a/meta-python/recipes-devtools/python/python3-marshmallow_3.14.1.bb b/meta-python/recipes-devtools/python/python3-marshmallow_3.15.0.bb
similarity index 76%
rename from meta-python/recipes-devtools/python/python3-marshmallow_3.14.1.bb
rename to meta-python/recipes-devtools/python/python3-marshmallow_3.15.0.bb
index dc5f17388..c8e0fa4dd 100644
--- a/meta-python/recipes-devtools/python/python3-marshmallow_3.14.1.bb
+++ b/meta-python/recipes-devtools/python/python3-marshmallow_3.15.0.bb
@@ -9,7 +9,7 @@  LIC_FILES_CHKSUM = "\
 
 SRC_URI = "git://github.com/marshmallow-code/marshmallow.git;protocol=https;branch=dev"
 
-SRCREV = "41afdefd93afd1b95f48f45fd284ff8add3e91b7"
+SRCREV = "f251dfb08d79c755c2e95371f2c5580bf5937e60"
 
 S = "${WORKDIR}/git"
 
@@ -17,4 +17,12 @@  inherit setuptools3
 
 PIP_INSTALL_PACKAGE = "marshmallow"
 
-RDEPENDS:${PN} += "python3-core"
+RDEPENDS:${PN} += " \
+	python3-core \
+	python3-datetime \
+	python3-netclient \
+	python3-numbers \
+	python3-json \
+	python3-pprint \
+	python3-packaging \
+"