[meta-oe,2/3] libirecovery: add recipe

Message ID 20220329024856.27349-3-potin.lai@quantatw.com
State Under Review
Headers show
Series add idevicerestore support | expand

Commit Message

Potin Lai March 29, 2022, 2:48 a.m. UTC
libirecovery is a cross-platform library which implements communication
to iBoot/iBSS found on Apple's iOS devices via USB.

Signed-off-by: Potin Lai <potin.lai@quantatw.com>
---
 .../libirecovery/libirecovery_git.bb              | 15 +++++++++++++++
 1 file changed, 15 insertions(+)
 create mode 100644 meta-oe/recipes-connectivity/libirecovery/libirecovery_git.bb

Comments

Khem Raj March 29, 2022, 3:18 p.m. UTC | #1
this fails for mips with

undefined reference to `bswap64'

https://errors.yoctoproject.org/Errors/Details/653670/

On Mon, Mar 28, 2022 at 7:49 PM Potin Lai <potin.lai@quantatw.com> wrote:
>
> libirecovery is a cross-platform library which implements communication
> to iBoot/iBSS found on Apple's iOS devices via USB.
>
> Signed-off-by: Potin Lai <potin.lai@quantatw.com>
> ---
>  .../libirecovery/libirecovery_git.bb              | 15 +++++++++++++++
>  1 file changed, 15 insertions(+)
>  create mode 100644 meta-oe/recipes-connectivity/libirecovery/libirecovery_git.bb
>
> diff --git a/meta-oe/recipes-connectivity/libirecovery/libirecovery_git.bb b/meta-oe/recipes-connectivity/libirecovery/libirecovery_git.bb
> new file mode 100644
> index 000000000..30c633caf
> --- /dev/null
> +++ b/meta-oe/recipes-connectivity/libirecovery/libirecovery_git.bb
> @@ -0,0 +1,15 @@
> +SUMMARY = "The libirecovery library allows communication with iBoot/iBSS of iOS devices via USB"
> +LICENSE = "LGPL-2.1"
> +LIC_FILES_CHKSUM = "\
> +    file://COPYING;md5=23c2a5e0106b99d75238986559bb5fc6 \
> +"
> +
> +HOMEPAGE = "http://www.libimobiledevice.org/"
> +
> +DEPENDS = "libimobiledevice-glue libusb1"
> +
> +SRCREV = "e19094594552b7bed60418ffe6f46f455e6bb78f"
> +SRC_URI = "git://github.com/libimobiledevice/libirecovery;protocol=https;branch=master"
> +
> +S = "${WORKDIR}/git"
> +inherit autotools pkgconfig
> --
> 2.17.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#96249): https://lists.openembedded.org/g/openembedded-devel/message/96249
> Mute This Topic: https://lists.openembedded.org/mt/90101059/1997914
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>

Patch

diff --git a/meta-oe/recipes-connectivity/libirecovery/libirecovery_git.bb b/meta-oe/recipes-connectivity/libirecovery/libirecovery_git.bb
new file mode 100644
index 000000000..30c633caf
--- /dev/null
+++ b/meta-oe/recipes-connectivity/libirecovery/libirecovery_git.bb
@@ -0,0 +1,15 @@ 
+SUMMARY = "The libirecovery library allows communication with iBoot/iBSS of iOS devices via USB"
+LICENSE = "LGPL-2.1"
+LIC_FILES_CHKSUM = "\
+    file://COPYING;md5=23c2a5e0106b99d75238986559bb5fc6 \
+"
+
+HOMEPAGE = "http://www.libimobiledevice.org/"
+
+DEPENDS = "libimobiledevice-glue libusb1"
+
+SRCREV = "e19094594552b7bed60418ffe6f46f455e6bb78f"
+SRC_URI = "git://github.com/libimobiledevice/libirecovery;protocol=https;branch=master"
+
+S = "${WORKDIR}/git"
+inherit autotools pkgconfig