[5/9] python3-pyzmq: clean up recipe

Message ID 20220310132523.2253188-5-ross.burton@arm.com
State New
Headers show
Series [1/9] packagegroup-meta-python: add poetry-core and unattended-upgrade | expand

Commit Message

Ross Burton March 10, 2022, 1:25 p.m. UTC
Put the patch into a directory named after PN to avoid needing to set
FILESEXTRAPATHS.

Remove explicit FILES:${PN}-dbg, as these are packaged automatically.

Signed-off-by: Ross Burton <ross.burton@arm.com>
---
 .../{python-pyzmq => python3-pyzmq}/club-rpath-out.patch      | 0
 meta-python/recipes-devtools/python/python3-pyzmq_22.3.0.bb   | 4 ----
 2 files changed, 4 deletions(-)
 rename meta-python/recipes-devtools/python/{python-pyzmq => python3-pyzmq}/club-rpath-out.patch (100%)

Patch

diff --git a/meta-python/recipes-devtools/python/python-pyzmq/club-rpath-out.patch b/meta-python/recipes-devtools/python/python3-pyzmq/club-rpath-out.patch
similarity index 100%
rename from meta-python/recipes-devtools/python/python-pyzmq/club-rpath-out.patch
rename to meta-python/recipes-devtools/python/python3-pyzmq/club-rpath-out.patch
diff --git a/meta-python/recipes-devtools/python/python3-pyzmq_22.3.0.bb b/meta-python/recipes-devtools/python/python3-pyzmq_22.3.0.bb
index 09e7341877..d2893ccbb1 100644
--- a/meta-python/recipes-devtools/python/python3-pyzmq_22.3.0.bb
+++ b/meta-python/recipes-devtools/python/python3-pyzmq_22.3.0.bb
@@ -5,8 +5,6 @@  LIC_FILES_CHKSUM = "file://COPYING.BSD;md5=11c65680f637c3df7f58bbc8d133e96e \
                     file://COPYING.LESSER;md5=12c592fa0bcfff3fb0977b066e9cb69e"
 DEPENDS = "zeromq"
 
-FILESEXTRAPATHS:prepend := "${THISDIR}/python-pyzmq:"
-
 SRC_URI += "file://club-rpath-out.patch"
 SRC_URI[sha256sum] = "8eddc033e716f8c91c6a2112f0a8ebc5e00532b4a6ae1eb0ccc48e027f9c671c"
 
@@ -17,8 +15,6 @@  RDEPENDS:${PN} += " \
 	${PYTHON_PN}-json \
 "
 
-FILES:${PN}-dbg =+ "${PYTHON_SITEPACKAGES_DIR}/zmq/backend/cython/.debug"
-
 do_compile:prepend() {
     echo [global] > ${S}/setup.cfg
     echo zmq_prefix = ${STAGING_DIR_HOST} >> ${S}/setup.cfg