[meta-oe] gosu: add new recipe

Message ID 20220304095656.4193707-1-mingli.yu@windriver.com
State New
Headers show
Series [meta-oe] gosu: add new recipe | expand

Commit Message

Yu, Mingli March 4, 2022, 9:56 a.m. UTC
From: Mingli Yu <mingli.yu@windriver.com>

gosu is a simple Go-based setuid+setgid+setgroups+exec tool.

Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
---
 meta-oe/recipes-support/gosu/gosu_1.14.bb | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)
 create mode 100644 meta-oe/recipes-support/gosu/gosu_1.14.bb

Patch

diff --git a/meta-oe/recipes-support/gosu/gosu_1.14.bb b/meta-oe/recipes-support/gosu/gosu_1.14.bb
new file mode 100644
index 000000000..624adf309
--- /dev/null
+++ b/meta-oe/recipes-support/gosu/gosu_1.14.bb
@@ -0,0 +1,20 @@ 
+SUMMARY = "Simple Go-based setuid+setgid+setgroups+exec"
+HOMEPAGE = "https://github.com/tianon/gosu"
+DESCRIPTION = "This is a simple tool grown out of the simple fact that su and sudo have very strange and often annoying TTY and signal-forwarding behavior."
+LICENSE = "Apache-2.0 "
+LIC_FILES_CHKSUM = "file://src/${GO_IMPORT}/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+GO_IMPORT = "github.com/tianon/gosu"
+SRC_URI = "git://${GO_IMPORT}.git;branch=master;protocol=https \
+           git://github.com/opencontainers/runc;name=runc;destsuffix=${S}/src/github.com/opencontainers/runc;branch=main;protocol=https \
+"
+SRCREV = "9f7cd138a1ebc0684d43ef6046bf723978e8741f"
+SRCREV_runc = "d7f7b22a85a2387557bdcda125710c2506f8d5c5"
+inherit go
+
+do_compile:prepend() {
+    # New Go versions has Go modules support enabled by default
+    export GO111MODULE=off
+}
+
+RDEPENDS:${PN}-dev += "bash"