[meta-python] python3-bitarray: switch to setuptools

Message ID 20220228202343.3386-1-jsbronder@cold-front.org
State New
Headers show
Series [meta-python] python3-bitarray: switch to setuptools | expand

Commit Message

Justin Bronder Feb. 28, 2022, 8:23 p.m. UTC
Backported patch from https://github.com/ilanschnell/bitarray/pull/168,
committed upstream as
https://github.com/ilanschnell/bitarray/commit/947d364841954d60bab7a4cf1497a272b1bf73ca

Signed-off-by: Justin Bronder <jsbronder@cold-front.org>
---
 ...-use-setuptools-instead-of-distutils.patch | 29 +++++++++++++++++++
 .../python/python3-bitarray_2.3.7.bb          |  3 ++
 2 files changed, 32 insertions(+)
 create mode 100644 meta-python/recipes-devtools/python/python3-bitarray/setup.py-use-setuptools-instead-of-distutils.patch

Patch

diff --git a/meta-python/recipes-devtools/python/python3-bitarray/setup.py-use-setuptools-instead-of-distutils.patch b/meta-python/recipes-devtools/python/python3-bitarray/setup.py-use-setuptools-instead-of-distutils.patch
new file mode 100644
index 0000000000..cef7ce15a4
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-bitarray/setup.py-use-setuptools-instead-of-distutils.patch
@@ -0,0 +1,29 @@ 
+From 947d364841954d60bab7a4cf1497a272b1bf73ca Mon Sep 17 00:00:00 2001
+From: Konrad Weihmann <kweihmann@outlook.com>
+Date: Sun, 27 Feb 2022 11:57:09 +0100
+Subject: [PATCH] setup.py: use setuptools instead of distutils
+
+as distutils will be deprecated in python 3.12 and already produces
+a warning when run with python 3.10.x, it might be a good time to
+switch to setuptools.
+It offers the same interface, so results will be the same
+
+Signed-off-by: Konrad Weihmann <kweihmann@outlook.com>
+
+Upstream-Status: Backport [https://github.com/ilanschnell/bitarray/commit/947d364841954d60bab7a4cf1497a272b1bf73ca]
+
+---
+ setup.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/setup.py b/setup.py
+index 4dbdf859..c7787dad 100644
+--- a/setup.py
++++ b/setup.py
+@@ -1,5 +1,5 @@
+ import re
+-from distutils.core import setup, Extension
++from setuptools import setup, Extension
+ 
+ 
+ kwds = {}
diff --git a/meta-python/recipes-devtools/python/python3-bitarray_2.3.7.bb b/meta-python/recipes-devtools/python/python3-bitarray_2.3.7.bb
index cac003a4fb..6566f8d664 100644
--- a/meta-python/recipes-devtools/python/python3-bitarray_2.3.7.bb
+++ b/meta-python/recipes-devtools/python/python3-bitarray_2.3.7.bb
@@ -7,4 +7,7 @@  SRC_URI[sha256sum] = "4da790ab193e993107f3ff0aebc4f8d6ad5196a19071fbafad16b02898
 
 inherit setuptools3 pypi
 
+# Backported from 2.3.8
+SRC_URI += "file://setup.py-use-setuptools-instead-of-distutils.patch"
+
 BBCLASSEXTEND = "native nativesdk"