[meta-python] python3-coloredlogs: fix location of coloredlogs.pth

Message ID 20220228184839.31132-1-jsbronder@cold-front.org
State New
Headers show
Series [meta-python] python3-coloredlogs: fix location of coloredlogs.pth | expand

Commit Message

Justin Bronder Feb. 28, 2022, 6:48 p.m. UTC
When calling setup.py with bdist_wheel, the find_pth_directory() in
setup.py correctly install the pth file to
${D}${PYTHON_SITEPACKAGES_DIR}.  It's not clear why setup.py was being
patched original when the recipe was added in 2019, but it doesn't
appear to be necessary now.

This fixes the recipe to build with the recent PEP-517 changes.

Signed-off-by: Justin Bronder <jsbronder@cold-front.org>
---
 .../recipes-devtools/python/python3-coloredlogs_15.0.1.bb     | 4 ----
 1 file changed, 4 deletions(-)

Patch

diff --git a/meta-python/recipes-devtools/python/python3-coloredlogs_15.0.1.bb b/meta-python/recipes-devtools/python/python3-coloredlogs_15.0.1.bb
index 9eafbaa3c6..d17ab87525 100644
--- a/meta-python/recipes-devtools/python/python3-coloredlogs_15.0.1.bb
+++ b/meta-python/recipes-devtools/python/python3-coloredlogs_15.0.1.bb
@@ -8,10 +8,6 @@  SRC_URI[sha256sum] = "7c991aa71a4577af2f82600d8f8f3a89f936baeaf9b50a9c197da014e5
 
 inherit pypi setuptools3
 
-do_compile:prepend() {
-    sed -ie "s/find_pth_directory(),/'',/g" ${S}/setup.py
-}
-
 do_install:append() {
     rm -rf ${D}${datadir}
 }