[meta-oe,4/6] sanlock: Fix build with wheels on

Message ID 20220227075848.610467-4-raj.khem@gmail.com
State New
Headers show
Series [meta-oe,1/6] python3-apt: Point PYPA_WHEEL to custom location | expand

Commit Message

Khem Raj Feb. 27, 2022, 7:58 a.m. UTC
Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 meta-oe/recipes-extended/sanlock/sanlock_3.8.4.bb | 3 +++
 1 file changed, 3 insertions(+)

Patch

diff --git a/meta-oe/recipes-extended/sanlock/sanlock_3.8.4.bb b/meta-oe/recipes-extended/sanlock/sanlock_3.8.4.bb
index 3c08c4e003..4bfd67e27b 100644
--- a/meta-oe/recipes-extended/sanlock/sanlock_3.8.4.bb
+++ b/meta-oe/recipes-extended/sanlock/sanlock_3.8.4.bb
@@ -26,6 +26,9 @@  DEPENDS = "libaio util-linux"
 inherit setuptools3 useradd
 
 SETUPTOOLS_SETUP_PATH = "${S}/python"
+PIP_INSTALL_DIST_PATH = "${B}/python/dist"
+PIP_INSTALL_PACKAGE = "sanlock_python"
+PYPA_WHEEL = "${PIP_INSTALL_DIST_PATH}/${PIP_INSTALL_PACKAGE}-3.8.4-*.whl"
 
 do_compile:prepend () {
     oe_runmake -C ${S}/wdmd CMD_LDFLAGS="${LDFLAGS}" LIB_LDFLAGS="${LDFLAGS}"