[meta-oe] python3-distutils-extra; merge inc, fix wheel build

Message ID 20220226004831.682543-1-tim.orling@konsulko.com
State New
Headers show
Series [meta-oe] python3-distutils-extra; merge inc, fix wheel build | expand

Commit Message

Tim Orling Feb. 26, 2022, 12:48 a.m. UTC
We have not supported Python2 for quite some time now, so there is no
reason to maintain a separate inc file.

This recipe does not inherit pypi and the PN does not match the built
wheel. Set PIP_INSTALL_PACKAGE appropriately so the wheel can be found.

Signed-off-by: Tim Orling <tim.orling@konsulko.com>
---
 .../recipes-devtools/python/python3-distutils-extra.bb   | 9 ---------
 ...stutils-extra.inc => python3-distutils-extra_2.39.bb} | 8 ++++++--
 2 files changed, 6 insertions(+), 11 deletions(-)
 delete mode 100644 meta-oe/recipes-devtools/python/python3-distutils-extra.bb
 rename meta-oe/recipes-devtools/python/{python-distutils-extra.inc => python3-distutils-extra_2.39.bb} (82%)

Patch

diff --git a/meta-oe/recipes-devtools/python/python3-distutils-extra.bb b/meta-oe/recipes-devtools/python/python3-distutils-extra.bb
deleted file mode 100644
index 580842d0d6..0000000000
--- a/meta-oe/recipes-devtools/python/python3-distutils-extra.bb
+++ /dev/null
@@ -1,9 +0,0 @@ 
-require python-distutils-extra.inc
-
-inherit setuptools3
-
-S = "${WORKDIR}/python-distutils-extra-${PV}"
-
-RDEPENDS:${PN} = "\
-    python3-setuptools \
-"
diff --git a/meta-oe/recipes-devtools/python/python-distutils-extra.inc b/meta-oe/recipes-devtools/python/python3-distutils-extra_2.39.bb
similarity index 82%
rename from meta-oe/recipes-devtools/python/python-distutils-extra.inc
rename to meta-oe/recipes-devtools/python/python3-distutils-extra_2.39.bb
index 3430cedf63..8aca4ca3ac 100644
--- a/meta-oe/recipes-devtools/python/python-distutils-extra.inc
+++ b/meta-oe/recipes-devtools/python/python3-distutils-extra_2.39.bb
@@ -5,9 +5,13 @@  SECTION = "devel/python"
 LICENSE = "GPLv2"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=4325afd396febcb659c36b49533135d4"
 
-PV = "2.39"
 SRC_URI = "https://launchpad.net/python-distutils-extra/trunk/${PV}/+download/python-distutils-extra-${PV}.tar.gz"
-SRC_URI[md5sum] = "16e06db0ef73a35b4bff4b9eed5699b5"
 SRC_URI[sha256sum] = "723f24f4d65fc8d99b33a002fbbb3771d4cc9d664c97085bf37f3997ae8063af"
 
+inherit setuptools3
+
+PIP_INSTALL_PACKAGE = "python_distutils_extra"
+
+S = "${WORKDIR}/python-distutils-extra-${PV}"
+
 BBCLASSEXTEND = "native"