[meta-python,2/2] netplan: Add knob to enable tests

Message ID 20220224080219.1354957-2-raj.khem@gmail.com
State New
Headers show
Series [meta-python,1/2] python3-oauthlib: Drop redundant nose dependency | expand

Commit Message

Khem Raj Feb. 24, 2022, 8:02 a.m. UTC
this puts python3-nose away from default requirements, nose dependency
should eventually be removed and perhaps converted to pytest

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 .../recipes-connectivity/netplan/netplan_0.104.bb           | 6 +++++-
 1 file changed, 5 insertions(+), 1 deletion(-)

Patch

diff --git a/meta-networking/recipes-connectivity/netplan/netplan_0.104.bb b/meta-networking/recipes-connectivity/netplan/netplan_0.104.bb
index 6a32f55d47..e26649744c 100644
--- a/meta-networking/recipes-connectivity/netplan/netplan_0.104.bb
+++ b/meta-networking/recipes-connectivity/netplan/netplan_0.104.bb
@@ -22,7 +22,11 @@  SRC_URI:append:libc-musl = " file://0001-don-t-fail-if-GLOB_BRACE-is-not-defined
 
 DEPENDS = "glib-2.0 libyaml ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
 
-RDEPENDS:${PN} = "python3 python3-core python3-pyyaml python3-netifaces python3-nose python3-coverage python3-pycodestyle python3-pyflakes util-linux-libuuid libnetplan"
+PACKAGECONFIG ?= ""
+
+PACKAGECONFIG[tests] = ",,,python3-nose python3-coverage python3-netifaces python3-pycodestyle python3-pyflakes python3-pyyaml"
+
+RDEPENDS:${PN} = "python3 python3-core python3-netifaces python3-pyyaml util-linux-libuuid libnetplan"
 
 inherit pkgconfig systemd