[meta-networking] dhcp-relay: regenerate configure for bundled bind

Message ID 20211230021012.1046899-1-yi.zhao@windriver.com
State New
Headers show
Series [meta-networking] dhcp-relay: regenerate configure for bundled bind | expand

Commit Message

Yi Zhao Dec. 30, 2021, 2:10 a.m. UTC
Run autogen.sh to regenerate configure for bundled bind. Then we can
avoid copying config.*, *.m4 and libtool from external. This can also
eliminate the relink warnings in do_install:

  libtool: warning: relinking 'libdns.la'
  libtool: warning: relinking 'libisccfg.la'

Signed-off-by: Yi Zhao <yi.zhao@windriver.com>
---
 .../dhcp/dhcp-relay_4.4.2p1.bb                | 14 ++-------
 ...ind-Makefile.in-regenerate-configure.patch | 30 +++++++++++++++++++
 2 files changed, 32 insertions(+), 12 deletions(-)
 create mode 100644 meta-networking/recipes-connectivity/dhcp/files/0004-bind-Makefile.in-regenerate-configure.patch

Comments

Khem Raj Dec. 30, 2021, 2:28 a.m. UTC | #1
On Wed, Dec 29, 2021 at 6:10 PM Yi Zhao <yi.zhao@windriver.com> wrote:
>
> Run autogen.sh to regenerate configure for bundled bind. Then we can
> avoid copying config.*, *.m4 and libtool from external. This can also
> eliminate the relink warnings in do_install:
>
>   libtool: warning: relinking 'libdns.la'
>   libtool: warning: relinking 'libisccfg.la'
>

wouldn't this now delegate downloading of bind to do_configure ?
if so then its not good.

> Signed-off-by: Yi Zhao <yi.zhao@windriver.com>
> ---
>  .../dhcp/dhcp-relay_4.4.2p1.bb                | 14 ++-------
>  ...ind-Makefile.in-regenerate-configure.patch | 30 +++++++++++++++++++
>  2 files changed, 32 insertions(+), 12 deletions(-)
>  create mode 100644 meta-networking/recipes-connectivity/dhcp/files/0004-bind-Makefile.in-regenerate-configure.patch
>
> diff --git a/meta-networking/recipes-connectivity/dhcp/dhcp-relay_4.4.2p1.bb b/meta-networking/recipes-connectivity/dhcp/dhcp-relay_4.4.2p1.bb
> index c86926813..f374d75b3 100644
> --- a/meta-networking/recipes-connectivity/dhcp/dhcp-relay_4.4.2p1.bb
> +++ b/meta-networking/recipes-connectivity/dhcp/dhcp-relay_4.4.2p1.bb
> @@ -18,6 +18,7 @@ SRC_URI = "https://ftp.isc.org/isc/dhcp/4.4.2-P1/dhcp-4.4.2-P1.tar.gz \
>             file://0001-Makefile.am-only-build-dhcrelay.patch \
>             file://0002-bind-version-update-to-latest-version.patch \
>             file://0003-bind-Makefile.in-disable-backtrace.patch \
> +           file://0004-bind-Makefile.in-regenerate-configure.patch \
>             "
>
>  SRC_URI[md5sum] = "3089a1ebd20a802ec0870ae337d43907"
> @@ -30,7 +31,7 @@ UPSTREAM_CHECK_REGEX = "(?P<pver>\d+\.\d+\.(\d+?))/"
>
>  S = "${WORKDIR}/dhcp-4.4.2-P1"
>
> -inherit autotools-brokensep systemd
> +inherit autotools-brokensep systemd pkgconfig
>
>  SYSTEMD_SERVICE:${PN} = "dhcrelay.service"
>  SYSTEMD_AUTO_ENABLE:${PN} = "disable"
> @@ -50,17 +51,6 @@ do_configure:prepend () {
>      cp ${WORKDIR}/bind-9.11.32.tar.gz ${S}/bind/bind.tar.gz
>  }
>
> -do_compile:prepend() {
> -    # Need to unpack this now instead of earlier as do_configure will delete the configure script
> -    rm -rf ${S}/bind/bind-9.11.32/
> -    tar xf ${S}/bind/bind.tar.gz -C ${S}/bind
> -    install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.guess ${S}/bind/bind-9.11.32/
> -    install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.sub ${S}/bind/bind-9.11.32/
> -    cp -fpR ${S}/m4/*.m4 ${S}/bind/bind-9.11.32/libtool.m4/
> -    rm -rf ${S}/bind/bind-9.11.32/libtool
> -    install -m 0755 ${S}/libtool ${S}/bind/bind-9.11.32/
> -}
> -
>  do_install:append () {
>      install -d ${D}${sysconfdir}/default
>      install -m 0644 ${WORKDIR}/default-relay ${D}${sysconfdir}/default/dhcp-relay
> diff --git a/meta-networking/recipes-connectivity/dhcp/files/0004-bind-Makefile.in-regenerate-configure.patch b/meta-networking/recipes-connectivity/dhcp/files/0004-bind-Makefile.in-regenerate-configure.patch
> new file mode 100644
> index 000000000..d97b2f7c4
> --- /dev/null
> +++ b/meta-networking/recipes-connectivity/dhcp/files/0004-bind-Makefile.in-regenerate-configure.patch
> @@ -0,0 +1,30 @@
> +From db4bfa34ff6e083936bc7d62908790b4d9f0ed8c Mon Sep 17 00:00:00 2001
> +From: Yi Zhao <yi.zhao@windriver.com>
> +Date: Thu, 27 May 2021 11:38:36 +0800
> +Subject: [PATCH] bind/Makefile.in: regenerate configure
> +
> +Run autogen.sh to regenerate configure.
> +
> +Upstream-Status: Inappropriate [embedded specific]
> +
> +Signed-off-by: Yi Zhao <yi.zhao@windriver.com>
> +---
> + bind/Makefile.in | 2 +-
> + 1 file changed, 1 insertion(+), 1 deletion(-)
> +
> +diff --git a/bind/Makefile.in b/bind/Makefile.in
> +index 1058160..f9c9f86 100644
> +--- a/bind/Makefile.in
> ++++ b/bind/Makefile.in
> +@@ -55,7 +55,7 @@ bind1:
> +       else                                                            \
> +               echo Configuring BIND libraries for DHCP. ;             \
> +               rm -rf ${cleandirs} ${cleanfiles} ;                     \
> +-              (cd ${bindsrcdir} &&                                    \
> ++              (cd ${bindsrcdir} && ./autogen.sh &&                    \
> +                  ./configure ${bindconfig} > ${binddir}/configure.log); \
> +       fi
> +
> +--
> +2.17.1
> +
> --
> 2.25.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#94564): https://lists.openembedded.org/g/openembedded-devel/message/94564
> Mute This Topic: https://lists.openembedded.org/mt/88027875/1997914
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Yi Zhao Dec. 30, 2021, 4:01 a.m. UTC | #2
On 12/30/21 10:28 AM, Khem Raj wrote:
> On Wed, Dec 29, 2021 at 6:10 PM Yi Zhao <yi.zhao@windriver.com> wrote:
>> Run autogen.sh to regenerate configure for bundled bind. Then we can
>> avoid copying config.*, *.m4 and libtool from external. This can also
>> eliminate the relink warnings in do_install:
>>
>>    libtool: warning: relinking 'libdns.la'
>>    libtool: warning: relinking 'libisccfg.la'
>>
> wouldn't this now delegate downloading of bind to do_configure ?
> if so then its not good.


No. we still download bind in do_fetch. and copy the tarball to build 
directory in do_configure:prepend.


//Yi

>
>> Signed-off-by: Yi Zhao <yi.zhao@windriver.com>
>> ---
>>   .../dhcp/dhcp-relay_4.4.2p1.bb                | 14 ++-------
>>   ...ind-Makefile.in-regenerate-configure.patch | 30 +++++++++++++++++++
>>   2 files changed, 32 insertions(+), 12 deletions(-)
>>   create mode 100644 meta-networking/recipes-connectivity/dhcp/files/0004-bind-Makefile.in-regenerate-configure.patch
>>
>> diff --git a/meta-networking/recipes-connectivity/dhcp/dhcp-relay_4.4.2p1.bb b/meta-networking/recipes-connectivity/dhcp/dhcp-relay_4.4.2p1.bb
>> index c86926813..f374d75b3 100644
>> --- a/meta-networking/recipes-connectivity/dhcp/dhcp-relay_4.4.2p1.bb
>> +++ b/meta-networking/recipes-connectivity/dhcp/dhcp-relay_4.4.2p1.bb
>> @@ -18,6 +18,7 @@ SRC_URI = "https://ftp.isc.org/isc/dhcp/4.4.2-P1/dhcp-4.4.2-P1.tar.gz \
>>              file://0001-Makefile.am-only-build-dhcrelay.patch \
>>              file://0002-bind-version-update-to-latest-version.patch \
>>              file://0003-bind-Makefile.in-disable-backtrace.patch \
>> +           file://0004-bind-Makefile.in-regenerate-configure.patch \
>>              "
>>
>>   SRC_URI[md5sum] = "3089a1ebd20a802ec0870ae337d43907"
>> @@ -30,7 +31,7 @@ UPSTREAM_CHECK_REGEX = "(?P<pver>\d+\.\d+\.(\d+?))/"
>>
>>   S = "${WORKDIR}/dhcp-4.4.2-P1"
>>
>> -inherit autotools-brokensep systemd
>> +inherit autotools-brokensep systemd pkgconfig
>>
>>   SYSTEMD_SERVICE:${PN} = "dhcrelay.service"
>>   SYSTEMD_AUTO_ENABLE:${PN} = "disable"
>> @@ -50,17 +51,6 @@ do_configure:prepend () {
>>       cp ${WORKDIR}/bind-9.11.32.tar.gz ${S}/bind/bind.tar.gz
>>   }
>>
>> -do_compile:prepend() {
>> -    # Need to unpack this now instead of earlier as do_configure will delete the configure script
>> -    rm -rf ${S}/bind/bind-9.11.32/
>> -    tar xf ${S}/bind/bind.tar.gz -C ${S}/bind
>> -    install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.guess ${S}/bind/bind-9.11.32/
>> -    install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.sub ${S}/bind/bind-9.11.32/
>> -    cp -fpR ${S}/m4/*.m4 ${S}/bind/bind-9.11.32/libtool.m4/
>> -    rm -rf ${S}/bind/bind-9.11.32/libtool
>> -    install -m 0755 ${S}/libtool ${S}/bind/bind-9.11.32/
>> -}
>> -
>>   do_install:append () {
>>       install -d ${D}${sysconfdir}/default
>>       install -m 0644 ${WORKDIR}/default-relay ${D}${sysconfdir}/default/dhcp-relay
>> diff --git a/meta-networking/recipes-connectivity/dhcp/files/0004-bind-Makefile.in-regenerate-configure.patch b/meta-networking/recipes-connectivity/dhcp/files/0004-bind-Makefile.in-regenerate-configure.patch
>> new file mode 100644
>> index 000000000..d97b2f7c4
>> --- /dev/null
>> +++ b/meta-networking/recipes-connectivity/dhcp/files/0004-bind-Makefile.in-regenerate-configure.patch
>> @@ -0,0 +1,30 @@
>> +From db4bfa34ff6e083936bc7d62908790b4d9f0ed8c Mon Sep 17 00:00:00 2001
>> +From: Yi Zhao <yi.zhao@windriver.com>
>> +Date: Thu, 27 May 2021 11:38:36 +0800
>> +Subject: [PATCH] bind/Makefile.in: regenerate configure
>> +
>> +Run autogen.sh to regenerate configure.
>> +
>> +Upstream-Status: Inappropriate [embedded specific]
>> +
>> +Signed-off-by: Yi Zhao <yi.zhao@windriver.com>
>> +---
>> + bind/Makefile.in | 2 +-
>> + 1 file changed, 1 insertion(+), 1 deletion(-)
>> +
>> +diff --git a/bind/Makefile.in b/bind/Makefile.in
>> +index 1058160..f9c9f86 100644
>> +--- a/bind/Makefile.in
>> ++++ b/bind/Makefile.in
>> +@@ -55,7 +55,7 @@ bind1:
>> +       else                                                            \
>> +               echo Configuring BIND libraries for DHCP. ;             \
>> +               rm -rf ${cleandirs} ${cleanfiles} ;                     \
>> +-              (cd ${bindsrcdir} &&                                    \
>> ++              (cd ${bindsrcdir} && ./autogen.sh &&                    \
>> +                  ./configure ${bindconfig} > ${binddir}/configure.log); \
>> +       fi
>> +
>> +--
>> +2.17.1
>> +
>> --
>> 2.25.1
>>
>>
>> -=-=-=-=-=-=-=-=-=-=-=-
>> Links: You receive all messages sent to this group.
>> View/Reply Online (#94564): https://lists.openembedded.org/g/openembedded-devel/message/94564
>> Mute This Topic: https://lists.openembedded.org/mt/88027875/1997914
>> Group Owner: openembedded-devel+owner@lists.openembedded.org
>> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
>> -=-=-=-=-=-=-=-=-=-=-=-
>>

Patch

diff --git a/meta-networking/recipes-connectivity/dhcp/dhcp-relay_4.4.2p1.bb b/meta-networking/recipes-connectivity/dhcp/dhcp-relay_4.4.2p1.bb
index c86926813..f374d75b3 100644
--- a/meta-networking/recipes-connectivity/dhcp/dhcp-relay_4.4.2p1.bb
+++ b/meta-networking/recipes-connectivity/dhcp/dhcp-relay_4.4.2p1.bb
@@ -18,6 +18,7 @@  SRC_URI = "https://ftp.isc.org/isc/dhcp/4.4.2-P1/dhcp-4.4.2-P1.tar.gz \
            file://0001-Makefile.am-only-build-dhcrelay.patch \
            file://0002-bind-version-update-to-latest-version.patch \
            file://0003-bind-Makefile.in-disable-backtrace.patch \
+           file://0004-bind-Makefile.in-regenerate-configure.patch \
            "
 
 SRC_URI[md5sum] = "3089a1ebd20a802ec0870ae337d43907"
@@ -30,7 +31,7 @@  UPSTREAM_CHECK_REGEX = "(?P<pver>\d+\.\d+\.(\d+?))/"
 
 S = "${WORKDIR}/dhcp-4.4.2-P1"
 
-inherit autotools-brokensep systemd
+inherit autotools-brokensep systemd pkgconfig
 
 SYSTEMD_SERVICE:${PN} = "dhcrelay.service"
 SYSTEMD_AUTO_ENABLE:${PN} = "disable"
@@ -50,17 +51,6 @@  do_configure:prepend () {
     cp ${WORKDIR}/bind-9.11.32.tar.gz ${S}/bind/bind.tar.gz
 }
 
-do_compile:prepend() {
-    # Need to unpack this now instead of earlier as do_configure will delete the configure script
-    rm -rf ${S}/bind/bind-9.11.32/
-    tar xf ${S}/bind/bind.tar.gz -C ${S}/bind
-    install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.guess ${S}/bind/bind-9.11.32/
-    install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.sub ${S}/bind/bind-9.11.32/
-    cp -fpR ${S}/m4/*.m4 ${S}/bind/bind-9.11.32/libtool.m4/
-    rm -rf ${S}/bind/bind-9.11.32/libtool
-    install -m 0755 ${S}/libtool ${S}/bind/bind-9.11.32/
-}
-
 do_install:append () {
     install -d ${D}${sysconfdir}/default
     install -m 0644 ${WORKDIR}/default-relay ${D}${sysconfdir}/default/dhcp-relay
diff --git a/meta-networking/recipes-connectivity/dhcp/files/0004-bind-Makefile.in-regenerate-configure.patch b/meta-networking/recipes-connectivity/dhcp/files/0004-bind-Makefile.in-regenerate-configure.patch
new file mode 100644
index 000000000..d97b2f7c4
--- /dev/null
+++ b/meta-networking/recipes-connectivity/dhcp/files/0004-bind-Makefile.in-regenerate-configure.patch
@@ -0,0 +1,30 @@ 
+From db4bfa34ff6e083936bc7d62908790b4d9f0ed8c Mon Sep 17 00:00:00 2001
+From: Yi Zhao <yi.zhao@windriver.com>
+Date: Thu, 27 May 2021 11:38:36 +0800
+Subject: [PATCH] bind/Makefile.in: regenerate configure
+
+Run autogen.sh to regenerate configure.
+
+Upstream-Status: Inappropriate [embedded specific]
+
+Signed-off-by: Yi Zhao <yi.zhao@windriver.com>
+---
+ bind/Makefile.in | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/bind/Makefile.in b/bind/Makefile.in
+index 1058160..f9c9f86 100644
+--- a/bind/Makefile.in
++++ b/bind/Makefile.in
+@@ -55,7 +55,7 @@ bind1:
+ 	else                                                            \
+ 		echo Configuring BIND libraries for DHCP. ;             \
+ 		rm -rf ${cleandirs} ${cleanfiles} ;                     \
+-		(cd ${bindsrcdir} &&                                    \
++		(cd ${bindsrcdir} && ./autogen.sh &&                    \
+                  ./configure ${bindconfig} > ${binddir}/configure.log); \
+ 	fi
+ 
+-- 
+2.17.1
+