diff mbox series

[meta-python] python3-pydantic: upgrade 2.5.3 -> 2.6.0

Message ID 1707209256-6015-1-git-send-email-wangmy@fujitsu.com
State Accepted
Headers show
Series [meta-python] python3-pydantic: upgrade 2.5.3 -> 2.6.0 | expand

Commit Message

Mingyu Wang (Fujitsu) Feb. 6, 2024, 8:47 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

Changelog:
============
-Drop Python3.7 support
-Drop Python 3.7, and PyPy 3.7 and 3.8
-Use positional-only self in BaseModel constructor, so no field name can ever
 conflict with it
-Make @validate_call return a function instead of a custom descriptor - fixes
 binding issue with inheritance and adds self/cls argument to validation errors 
-Exclude BaseModel docstring from JSON schema description
-Introducing classproperty decorator for model_computed_fields
-Explicitly raise an error if field names clashes with types
-Use stricter serializer for unions of simple types

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 .../{python3-pydantic_2.5.3.bb => python3-pydantic_2.6.0.bb}    | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta-python/recipes-devtools/python/{python3-pydantic_2.5.3.bb => python3-pydantic_2.6.0.bb} (94%)

Comments

Khem Raj Feb. 7, 2024, 6:52 p.m. UTC | #1
this fails ptests on qemux86-64

Failed ptests:
{'python3-pydantic': 'START: ptest-runner\n'
                     '2024-02-07T18:01\n'

'============================================================================\n'
                     'Testsuite summary\n'
                     '# TOTAL: 0\n'
                     '# PASS: 0\n'
                     '# SKIP: 0\n'
                     '# XFAIL: 0\n'
                     '# FAIL: 0\n'
                     '# XPASS: 0\n'

              '# ERROR: 0\n'
                     '\n'

              'ERROR: Exit status is 2\n'
                     'DURATION: 7\n'}

ptests which had no test results:
['python3-pydantic']

On Tue, Feb 6, 2024 at 12:48 AM wangmy via lists.openembedded.org
<wangmy=fujitsu.com@lists.openembedded.org> wrote:
>
> From: Wang Mingyu <wangmy@fujitsu.com>
>
> Changelog:
> ============
> -Drop Python3.7 support
> -Drop Python 3.7, and PyPy 3.7 and 3.8
> -Use positional-only self in BaseModel constructor, so no field name can ever
>  conflict with it
> -Make @validate_call return a function instead of a custom descriptor - fixes
>  binding issue with inheritance and adds self/cls argument to validation errors
> -Exclude BaseModel docstring from JSON schema description
> -Introducing classproperty decorator for model_computed_fields
> -Explicitly raise an error if field names clashes with types
> -Use stricter serializer for unions of simple types
>
> Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
> ---
>  .../{python3-pydantic_2.5.3.bb => python3-pydantic_2.6.0.bb}    | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>  rename meta-python/recipes-devtools/python/{python3-pydantic_2.5.3.bb => python3-pydantic_2.6.0.bb} (94%)
>
> diff --git a/meta-python/recipes-devtools/python/python3-pydantic_2.5.3.bb b/meta-python/recipes-devtools/python/python3-pydantic_2.6.0.bb
> similarity index 94%
> rename from meta-python/recipes-devtools/python/python3-pydantic_2.5.3.bb
> rename to meta-python/recipes-devtools/python/python3-pydantic_2.6.0.bb
> index 21341d26c..af465f423 100644
> --- a/meta-python/recipes-devtools/python/python3-pydantic_2.5.3.bb
> +++ b/meta-python/recipes-devtools/python/python3-pydantic_2.6.0.bb
> @@ -11,7 +11,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=09280955509d1c4ca14bae02f21d49a6"
>
>  inherit pypi python_hatchling
>
> -SRC_URI[sha256sum] = "b3ef57c62535b0941697cce638c08900d87fcb67e29cfa99e8a68f747f393f7a"
> +SRC_URI[sha256sum] = "ae887bd94eb404b09d86e4d12f93893bdca79d766e738528c6fa1c849f3c6bcf"
>
>  DEPENDS += "python3-hatch-fancy-pypi-readme-native"
>
> --
> 2.34.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#108619): https://lists.openembedded.org/g/openembedded-devel/message/108619
> Mute This Topic: https://lists.openembedded.org/mt/104194508/1997914
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Tim Orling Feb. 8, 2024, 4:07 a.m. UTC | #2
On Wed, Feb 7, 2024 at 10:53 AM Khem Raj <raj.khem@gmail.com> wrote:

> this fails ptests on qemux86-64
>
> Failed ptests:
> {'python3-pydantic': 'START: ptest-runner\n'
>                      '2024-02-07T18:01\n'
>
>
> '============================================================================\n'
>                      'Testsuite summary\n'
>                      '# TOTAL: 0\n'
>                      '# PASS: 0\n'
>                      '# SKIP: 0\n'
>                      '# XFAIL: 0\n'
>                      '# FAIL: 0\n'
>                      '# XPASS: 0\n'
>
>               '# ERROR: 0\n'
>                      '\n'
>
>               'ERROR: Exit status is 2\n'
>                      'DURATION: 7\n'}
>
> ptests which had no test results:
> ['python3-pydantic']
>

Thus might be because it also needs an upgrade of python3-pydantic-core
(and others)
https://docs.pydantic.dev/latest/changelog/#packaging_1


> On Tue, Feb 6, 2024 at 12:48 AM wangmy via lists.openembedded.org
> <wangmy=fujitsu.com@lists.openembedded.org> wrote:
> >
> > From: Wang Mingyu <wangmy@fujitsu.com>
> >
> > Changelog:
> > ============
> > -Drop Python3.7 support
> > -Drop Python 3.7, and PyPy 3.7 and 3.8
> > -Use positional-only self in BaseModel constructor, so no field name can
> ever
> >  conflict with it
> > -Make @validate_call return a function instead of a custom descriptor -
> fixes
> >  binding issue with inheritance and adds self/cls argument to validation
> errors
> > -Exclude BaseModel docstring from JSON schema description
> > -Introducing classproperty decorator for model_computed_fields
> > -Explicitly raise an error if field names clashes with types
> > -Use stricter serializer for unions of simple types
> >
> > Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
> > ---
> >  .../{python3-pydantic_2.5.3.bb => python3-pydantic_2.6.0.bb}    | 2 +-
> >  1 file changed, 1 insertion(+), 1 deletion(-)
> >  rename meta-python/recipes-devtools/python/{python3-pydantic_2.5.3.bb
> => python3-pydantic_2.6.0.bb} (94%)
> >
> > diff --git a/meta-python/recipes-devtools/python/
> python3-pydantic_2.5.3.bb b/meta-python/recipes-devtools/python/
> python3-pydantic_2.6.0.bb
> > similarity index 94%
> > rename from meta-python/recipes-devtools/python/
> python3-pydantic_2.5.3.bb
> > rename to meta-python/recipes-devtools/python/python3-pydantic_2.6.0.bb
> > index 21341d26c..af465f423 100644
> > --- a/meta-python/recipes-devtools/python/python3-pydantic_2.5.3.bb
> > +++ b/meta-python/recipes-devtools/python/python3-pydantic_2.6.0.bb
> > @@ -11,7 +11,7 @@ LIC_FILES_CHKSUM =
> "file://LICENSE;md5=09280955509d1c4ca14bae02f21d49a6"
> >
> >  inherit pypi python_hatchling
> >
> > -SRC_URI[sha256sum] =
> "b3ef57c62535b0941697cce638c08900d87fcb67e29cfa99e8a68f747f393f7a"
> > +SRC_URI[sha256sum] =
> "ae887bd94eb404b09d86e4d12f93893bdca79d766e738528c6fa1c849f3c6bcf"
> >
> >  DEPENDS += "python3-hatch-fancy-pypi-readme-native"
> >
> > --
> > 2.34.1
> >
> >
> >
> >
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#108653):
> https://lists.openembedded.org/g/openembedded-devel/message/108653
> Mute This Topic: https://lists.openembedded.org/mt/104194508/924729
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [
> ticotimo@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
>
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-pydantic_2.5.3.bb b/meta-python/recipes-devtools/python/python3-pydantic_2.6.0.bb
similarity index 94%
rename from meta-python/recipes-devtools/python/python3-pydantic_2.5.3.bb
rename to meta-python/recipes-devtools/python/python3-pydantic_2.6.0.bb
index 21341d26c..af465f423 100644
--- a/meta-python/recipes-devtools/python/python3-pydantic_2.5.3.bb
+++ b/meta-python/recipes-devtools/python/python3-pydantic_2.6.0.bb
@@ -11,7 +11,7 @@  LIC_FILES_CHKSUM = "file://LICENSE;md5=09280955509d1c4ca14bae02f21d49a6"
 
 inherit pypi python_hatchling
 
-SRC_URI[sha256sum] = "b3ef57c62535b0941697cce638c08900d87fcb67e29cfa99e8a68f747f393f7a"
+SRC_URI[sha256sum] = "ae887bd94eb404b09d86e4d12f93893bdca79d766e738528c6fa1c849f3c6bcf"
 
 DEPENDS += "python3-hatch-fancy-pypi-readme-native"