diff mbox series

[meta-python] python3-ldap: upgrade 3.4.3 -> 3.4.4

Message ID 1700634482-8100-1-git-send-email-wangmy@fujitsu.com
State Accepted
Headers show
Series [meta-python] python3-ldap: upgrade 3.4.3 -> 3.4.4 | expand

Commit Message

Mingyu Wang (Fujitsu) Nov. 22, 2023, 6:28 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

Changelog:
=============
-Reconnect race condition in ReconnectLDAPObject is now fixed
-Socket ownership is now claimed once we've passed it to libldap
-LDAP_set_option string formats are now compatible with Python 3.12
-Security Policy was created
-Broken article links are fixed now
-Bring Conscious Language improvements
-Add testing and document support for Python 3.10, 3.11, and 3.12

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 .../python/{python3-ldap_3.4.3.bb => python3-ldap_3.4.4.bb}     | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta-python/recipes-networking/python/{python3-ldap_3.4.3.bb => python3-ldap_3.4.4.bb} (90%)

Comments

Khem Raj Nov. 24, 2023, 12:01 a.m. UTC | #1
On Wed, 22 Nov 2023 14:28:02 +0800, wangmy@fujitsu.com wrote:
> Changelog:
> =============
> -Reconnect race condition in ReconnectLDAPObject is now fixed
> -Socket ownership is now claimed once we've passed it to libldap
> -LDAP_set_option string formats are now compatible with Python 3.12
> -Security Policy was created
> -Broken article links are fixed now
> -Bring Conscious Language improvements
> -Add testing and document support for Python 3.10, 3.11, and 3.12
> 
> [...]

Applied, thanks!

[1/1] python3-ldap: upgrade 3.4.3 -> 3.4.4
      commit: 0bfb7b316460850785880444efc5300ed2568acd

Best regards,
diff mbox series

Patch

diff --git a/meta-python/recipes-networking/python/python3-ldap_3.4.3.bb b/meta-python/recipes-networking/python/python3-ldap_3.4.4.bb
similarity index 90%
rename from meta-python/recipes-networking/python/python3-ldap_3.4.3.bb
rename to meta-python/recipes-networking/python/python3-ldap_3.4.4.bb
index 0bf1ff14a..6caf5f37c 100644
--- a/meta-python/recipes-networking/python/python3-ldap_3.4.3.bb
+++ b/meta-python/recipes-networking/python/python3-ldap_3.4.4.bb
@@ -13,7 +13,7 @@  PYPI_PACKAGE = "python-ldap"
 
 inherit pypi setuptools3
 
-SRC_URI[sha256sum] = "ab26c519a0ef2a443a2a10391fa3c5cb52d7871323399db949ebfaa9f25ee2a0"
+SRC_URI[sha256sum] = "7edb0accec4e037797705f3a05cbf36a9fde50d08c8f67f2aef99a2628fab828"
 
 do_configure:prepend() {
     sed -i -e 's:^library_dirs =.*::' \