diff mbox series

[meta-python] python3-typeguard: upgrade 4.1.3 -> 4.1.5

Message ID 1695110140-8206-1-git-send-email-wangmy@fujitsu.com
State Under Review
Headers show
Series [meta-python] python3-typeguard: upgrade 4.1.3 -> 4.1.5 | expand

Commit Message

Mingyu Wang (Fujitsu) Sept. 19, 2023, 7:55 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

Changelog:
=========
-Fixed Callable erroneously rejecting a callable that has the requested amount
 of positional arguments but they have defaults
-Fixed a regression introduced in v4.1.4 where the elements of Literal got
 quotes removed from them by the AST transformer
-Fixed AttributeError where the transformer removed elements from a PEP 604 union
-Fixed AttributeError: 'Subscript' object has no attribute 'slice' when
 encountering an annotation with a subscript containing an ignored type
 (imported within an if TYPE_CHECKING: block)
-Fixed type checking not being skipped when the target is a union (PEP 604 or
 typing.Union) where one of the elements is an ignored type (shadowed by an
 argument, variable assignment or an if TYPE_CHECKING import) (#394, #395)
-Fixed type checking of class instances created in __new__() in cases such as
 enums where this method is already invoked before the class has finished initializing

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 .../{python3-typeguard_4.1.3.bb => python3-typeguard_4.1.5.bb}  | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta-python/recipes-devtools/python/{python3-typeguard_4.1.3.bb => python3-typeguard_4.1.5.bb} (89%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-typeguard_4.1.3.bb b/meta-python/recipes-devtools/python/python3-typeguard_4.1.5.bb
similarity index 89%
rename from meta-python/recipes-devtools/python/python3-typeguard_4.1.3.bb
rename to meta-python/recipes-devtools/python/python3-typeguard_4.1.5.bb
index 73935d090c..53a02dc4bc 100644
--- a/meta-python/recipes-devtools/python/python3-typeguard_4.1.3.bb
+++ b/meta-python/recipes-devtools/python/python3-typeguard_4.1.5.bb
@@ -3,7 +3,7 @@  HOMEPAGE = "https://pypi.org/project/typeguard/"
 LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=f0e423eea5c91e7aa21bdb70184b3e53"
 
-SRC_URI[sha256sum] = "7d4264cd631ac1157c5bb5ec992281b4f1e2ba7a35db91bc15f442235e244803"
+SRC_URI[sha256sum] = "ea0a113bbc111bcffc90789ebb215625c963411f7096a7e9062d4e4630c155fd"
 
 inherit pypi python_setuptools_build_meta ptest