diff mbox series

[meta-oe] thrift: upgrade 0.18.1 -> 0.19.0

Message ID 1693965978-15157-1-git-send-email-wangmy@fujitsu.com
State New
Headers show
Series [meta-oe] thrift: upgrade 0.18.1 -> 0.19.0 | expand

Commit Message

Mingyu Wang (Fujitsu) Sept. 6, 2023, 2:06 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

Changelog:
===========
- C++ library don't work with HTTP (csharp server, cpp client; need cross test enhancement)
- Swift service generator doesn't support oneway
- LNK4042 and LNK2019 in go_validator_generator.cc
- Add dependabot
- Thrift SSL server stops working if the file descriptor returned is zero
- TMemoryBuffer resizing might shrink the buffer size due to uint32_t overflow
- Constant expects type to be defined before
- Add comparer and capacity arguments to container classes
- Handle ErrAbandonRequest automatically
- uuid sets and map keys may throw on some Haxe targets
- Superfluous block scope in generated write() code
- Haxe 4.30 emits "Local variable retval used without being initialized" on generated code
- Support for deprecated methods (via annotation)
- deprecation warning fixes for @:extern and @:enum
- Migration to JakartaEE and Apache HttpComponents 5
- FutureClient does not extend when service extends from another service
- Support Java 8
- TByteBuffer.java does not allow non-default TConfiguration
- Fix Java UUID typeid
- Server implementation exceptions are not sent to client in ES6 promise-style invocation
- Upgrade to net7.0
- NodeJS header transport leaks headers between all instances
- Php8.1 fix warnings
- add TJSONProtocol support in thrift-swift

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 .../thrift/{thrift_0.18.1.bb => thrift_0.19.0.bb}               | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta-oe/recipes-connectivity/thrift/{thrift_0.18.1.bb => thrift_0.19.0.bb} (96%)
diff mbox series

Patch

diff --git a/meta-oe/recipes-connectivity/thrift/thrift_0.18.1.bb b/meta-oe/recipes-connectivity/thrift/thrift_0.19.0.bb
similarity index 96%
rename from meta-oe/recipes-connectivity/thrift/thrift_0.18.1.bb
rename to meta-oe/recipes-connectivity/thrift/thrift_0.19.0.bb
index 2809e24ad1..70c9a7a087 100644
--- a/meta-oe/recipes-connectivity/thrift/thrift_0.18.1.bb
+++ b/meta-oe/recipes-connectivity/thrift/thrift_0.19.0.bb
@@ -10,7 +10,7 @@  DEPENDS = "thrift-native boost flex-native bison-native openssl zlib"
 
 SRC_URI = "https://downloads.apache.org/${BPN}/${PV}/${BP}.tar.gz \
            file://0001-DefineInstallationPaths.cmake-Define-libdir-in-terms.patch"
-SRC_URI[sha256sum] = "04c6f10e5d788ca78e13ee2ef0d2152c7b070c0af55483d6b942e29cff296726"
+SRC_URI[sha256sum] = "d49c896c2724a78701e05cfccf6cf70b5db312d82a17efe951b441d300ccf275"
 
 BBCLASSEXTEND = "native nativesdk"