diff mbox series

[meta-python] python3-pydantic: upgrade 1.10.5 -> 1.10.6

Message ID 1678889238-20738-4-git-send-email-wangmy@fujitsu.com
State Under Review
Headers show
Series [meta-python] python3-pydantic: upgrade 1.10.5 -> 1.10.6 | expand

Commit Message

Mingyu Wang (Fujitsu) March 15, 2023, 2:07 p.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

Changelog:
==========
- Implement logic to support creating validators from non standard callables by
  using defaults to identify them and unwrapping functools.partial and
  functools.partialmethod when checking the signature
- Fix mypy plugin for v1.1.1, and fix dataclass_transform decorator for pydantic dataclasses
- Raise ValidationError, not ConfigError, when a discriminator value is unhashable

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 .../{python3-pydantic_1.10.5.bb => python3-pydantic_1.10.6.bb}  | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta-python/recipes-devtools/python/{python3-pydantic_1.10.5.bb => python3-pydantic_1.10.6.bb} (85%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-pydantic_1.10.5.bb b/meta-python/recipes-devtools/python/python3-pydantic_1.10.6.bb
similarity index 85%
rename from meta-python/recipes-devtools/python/python3-pydantic_1.10.5.bb
rename to meta-python/recipes-devtools/python/python3-pydantic_1.10.6.bb
index 77e94a9bb..c888f4a5d 100644
--- a/meta-python/recipes-devtools/python/python3-pydantic_1.10.5.bb
+++ b/meta-python/recipes-devtools/python/python3-pydantic_1.10.6.bb
@@ -5,7 +5,7 @@  LIC_FILES_CHKSUM = "file://LICENSE;md5=2c02ea30650b91528657db64baea1757"
 
 inherit pypi setuptools3
 
-SRC_URI[sha256sum] = "9e337ac83686645a46db0e825acceea8e02fca4062483f40e9ae178e8bd1103a"
+SRC_URI[sha256sum] = "cf95adb0d1671fc38d8c43dd921ad5814a735e7d9b4d9e437c088002863854fd"
 
 RDEPENDS:${PN} += "\
     ${PYTHON_PN}-typing-extensions \