diff mbox series

[meta-python] python3-werkzeug: upgrade 2.2.1 -> 2.2.2

Message ID 1660705060-17241-5-git-send-email-wangmy@fujitsu.com
State Accepted, archived
Headers show
Series [meta-python] python3-werkzeug: upgrade 2.2.1 -> 2.2.2 | expand

Commit Message

Mingyu Wang (Fujitsu) Aug. 17, 2022, 2:57 a.m. UTC
Changelog:
==========
- Fix router to restore the 2.1 strict_slashes == False behaviour whereby
  leaf-requests match branch rules and vice versa.
- Fix router to identify invalid rules rather than hang parsing them, and
  to correctly parse / within converter arguments.
- Update subpackage imports in werkzeug.routing to use the import as syntax
  for explicitly re-exporting public attributes.
- Parsing of some invalid header characters is more robust.
- When starting the development server, a warning not to use it in a production
  deployment is always shown.
- LocalProxy.__wrapped__ is always set to the wrapped object when the proxy is
  unbound, fixing an issue in doctest that would cause it to fail.
- Address one ResourceWarning related to the socket used by run_simple.

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 .../{python3-werkzeug_2.2.1.bb => python3-werkzeug_2.2.2.bb}    | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta-python/recipes-devtools/python/{python3-werkzeug_2.2.1.bb => python3-werkzeug_2.2.2.bb} (93%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-werkzeug_2.2.1.bb b/meta-python/recipes-devtools/python/python3-werkzeug_2.2.2.bb
similarity index 93%
rename from meta-python/recipes-devtools/python/python3-werkzeug_2.2.1.bb
rename to meta-python/recipes-devtools/python/python3-werkzeug_2.2.2.bb
index d73235d253..92302f9cd7 100644
--- a/meta-python/recipes-devtools/python/python3-werkzeug_2.2.1.bb
+++ b/meta-python/recipes-devtools/python/python3-werkzeug_2.2.2.bb
@@ -12,7 +12,7 @@  LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=5dc88300786f1c214c1e9827a5229462"
 
 PYPI_PACKAGE = "Werkzeug"
 
-SRC_URI[sha256sum] = "4d7013ef96fd197d1cdeb03e066c6c5a491ccb44758a5b2b91137319383e5a5a"
+SRC_URI[sha256sum] = "7ea2d48322cc7c0f8b3a215ed73eabd7b5d75d0b50e31ab006286ccff9e00b8f"
 
 inherit pypi setuptools3