[meta-python,v2] python3-cppy: upgrade 1.2.0 -> 1.2.1

Message ID 1649605974-12443-2-git-send-email-wangmy@fujitsu.com
State New
Headers show
Series [meta-python,v2] python3-cppy: upgrade 1.2.0 -> 1.2.1 | expand

Commit Message

Mingyu Wang (Fujitsu) April 10, 2022, 3:52 p.m. UTC
Add patch 0001-Fix-build-bug.patch to fix build bug caused by
setup.py.

Changelog:
==========
make the pyproject.toml fully PEP 621 compliant PR #19

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 .../python3-cppy/0001-Fix-build-bug.patch     | 37 +++++++++++++++++++
 ...n3-cppy_1.2.0.bb => python3-cppy_1.2.1.bb} |  6 ++-
 2 files changed, 42 insertions(+), 1 deletion(-)
 create mode 100644 meta-python/recipes-devtools/python/python3-cppy/0001-Fix-build-bug.patch
 rename meta-python/recipes-devtools/python/{python3-cppy_1.2.0.bb => python3-cppy_1.2.1.bb} (69%)

Comments

Tim Orling April 13, 2022, 10:18 p.m. UTC | #1
NAK. Instead inherit python _setuptools-buils-meta


https://github.com/nucleic/cppy/blob/main/pyproject.toml#L42
Which shows build-backend = "setuptools.build_meta"

We do not want to carry patches when upstream has modernized.

On Wed, Apr 13, 2022 at 1:56 AM wangmy <wangmy@fujitsu.com> wrote:

> Add patch 0001-Fix-build-bug.patch to fix build bug caused by
> setup.py.
>
> Changelog:
> ==========
> make the pyproject.toml fully PEP 621 compliant PR #19
>
> Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
> ---
>  .../python3-cppy/0001-Fix-build-bug.patch     | 37 +++++++++++++++++++
>  ...n3-cppy_1.2.0.bb => python3-cppy_1.2.1.bb} |  6 ++-
>  2 files changed, 42 insertions(+), 1 deletion(-)
>  create mode 100644
> meta-python/recipes-devtools/python/python3-cppy/0001-Fix-build-bug.patch
>  rename meta-python/recipes-devtools/python/{python3-cppy_1.2.0.bb =>
> python3-cppy_1.2.1.bb} (69%)
>
> diff --git
> a/meta-python/recipes-devtools/python/python3-cppy/0001-Fix-build-bug.patch
> b/meta-python/recipes-devtools/python/python3-cppy/0001-Fix-build-bug.patch
> new file mode 100644
> index 0000000000..ada03b9a27
> --- /dev/null
> +++
> b/meta-python/recipes-devtools/python/python3-cppy/0001-Fix-build-bug.patch
> @@ -0,0 +1,37 @@
> +From 57733d2cece47095b3faf14090219fcb5fa8ca2c Mon Sep 17 00:00:00 2001
> +From: Lei Maohui <leimaohui@fujitsu.com>
> +Date: Wed, 13 Apr 2022 13:01:32 +0900
> +Subject: [PATCH] Fix build bug.
> +
> +Because the upstream cleared the setup.py, do_compile can't be excuted
> +correctly. So, recover setup.py from the last version.
> +
> +Upstream-Status: Pending
> +Signed-off-by: Lei Maohui <leimaohui@fujitsu.com>
> +---
> + setup.py | 12 +++++++++++-
> + 1 file changed, 11 insertions(+), 1 deletion(-)
> +
> +diff --git a/setup.py b/setup.py
> +index f6f8487..8dfc33f 100644
> +--- a/setup.py
> ++++ b/setup.py
> +@@ -7,4 +7,14 @@
> + #
> ------------------------------------------------------------------------------
> + from setuptools import setup
> +
> +-setup()
> ++setup(
> ++    name="cppy",
> ++    author="The Nucleic Development Team",
> ++    author_email="sccolbert@gmail.com",
> ++    maintainer_email="m.dartiailh@gmail.com",
> ++    url="https://github.com/nucleic/cppy",
> ++    description="C++ headers for C extension development",
> ++    long_description=open("README.rst").read(),
> ++    packages=["cppy"],
> ++    package_data={"cppy": ["include/cppy/*.h"]},
> ++)
> +--
> +2.25.1
> +
> diff --git a/meta-python/recipes-devtools/python/python3-cppy_1.2.0.bb
> b/meta-python/recipes-devtools/python/python3-cppy_1.2.1.bb
> similarity index 69%
> rename from meta-python/recipes-devtools/python/python3-cppy_1.2.0.bb
> rename to meta-python/recipes-devtools/python/python3-cppy_1.2.1.bb
> index f86f571938..b9f7f08227 100644
> --- a/meta-python/recipes-devtools/python/python3-cppy_1.2.0.bb
> +++ b/meta-python/recipes-devtools/python/python3-cppy_1.2.1.bb
> @@ -3,7 +3,11 @@ HOMEPAGE = "https://cppy.readthedocs.io/en/latest/"
>  LICENSE = "BSD-3-Clause"
>  LIC_FILES_CHKSUM = "file://LICENSE;md5=0bfb3e39b13587f0028f17baf0e42371"
>
> -SRC_URI[sha256sum] =
> "95e8862e4f826c3f2a6b7b658333b162f80cbe9f943aa0d0a7a6b2ef850aeffc"
> +SRC_URI += " \
> +    file://0001-Fix-build-bug.patch \
> +"
> +
> +SRC_URI[sha256sum] =
> "83b43bf17b1085ac15c5debdb42154f138b928234b21447358981f69d0d6fe1b"
>
>  RDEPENDS:${PN} += "python3-setuptools python3-distutils"
>
> --
> 2.25.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#96614):
> https://lists.openembedded.org/g/openembedded-devel/message/96614
> Mute This Topic: https://lists.openembedded.org/mt/90436671/924729
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [
> ticotimo@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
>

Patch

diff --git a/meta-python/recipes-devtools/python/python3-cppy/0001-Fix-build-bug.patch b/meta-python/recipes-devtools/python/python3-cppy/0001-Fix-build-bug.patch
new file mode 100644
index 0000000000..ada03b9a27
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-cppy/0001-Fix-build-bug.patch
@@ -0,0 +1,37 @@ 
+From 57733d2cece47095b3faf14090219fcb5fa8ca2c Mon Sep 17 00:00:00 2001
+From: Lei Maohui <leimaohui@fujitsu.com>
+Date: Wed, 13 Apr 2022 13:01:32 +0900
+Subject: [PATCH] Fix build bug.
+
+Because the upstream cleared the setup.py, do_compile can't be excuted
+correctly. So, recover setup.py from the last version.
+
+Upstream-Status: Pending
+Signed-off-by: Lei Maohui <leimaohui@fujitsu.com>
+---
+ setup.py | 12 +++++++++++-
+ 1 file changed, 11 insertions(+), 1 deletion(-)
+
+diff --git a/setup.py b/setup.py
+index f6f8487..8dfc33f 100644
+--- a/setup.py
++++ b/setup.py
+@@ -7,4 +7,14 @@
+ # ------------------------------------------------------------------------------
+ from setuptools import setup
+ 
+-setup()
++setup(
++    name="cppy",
++    author="The Nucleic Development Team",
++    author_email="sccolbert@gmail.com",
++    maintainer_email="m.dartiailh@gmail.com",
++    url="https://github.com/nucleic/cppy",
++    description="C++ headers for C extension development",
++    long_description=open("README.rst").read(),
++    packages=["cppy"],
++    package_data={"cppy": ["include/cppy/*.h"]},
++)
+-- 
+2.25.1
+
diff --git a/meta-python/recipes-devtools/python/python3-cppy_1.2.0.bb b/meta-python/recipes-devtools/python/python3-cppy_1.2.1.bb
similarity index 69%
rename from meta-python/recipes-devtools/python/python3-cppy_1.2.0.bb
rename to meta-python/recipes-devtools/python/python3-cppy_1.2.1.bb
index f86f571938..b9f7f08227 100644
--- a/meta-python/recipes-devtools/python/python3-cppy_1.2.0.bb
+++ b/meta-python/recipes-devtools/python/python3-cppy_1.2.1.bb
@@ -3,7 +3,11 @@  HOMEPAGE = "https://cppy.readthedocs.io/en/latest/"
 LICENSE = "BSD-3-Clause"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=0bfb3e39b13587f0028f17baf0e42371"
 
-SRC_URI[sha256sum] = "95e8862e4f826c3f2a6b7b658333b162f80cbe9f943aa0d0a7a6b2ef850aeffc"
+SRC_URI += " \
+    file://0001-Fix-build-bug.patch \
+"
+
+SRC_URI[sha256sum] = "83b43bf17b1085ac15c5debdb42154f138b928234b21447358981f69d0d6fe1b"
 
 RDEPENDS:${PN} += "python3-setuptools python3-distutils"