[3/5,meta-python] python3-async-timeout: upgrade 4.0.0 -> 4.0.2

Message ID 1642663344-16829-3-git-send-email-xuhuan.fnst@fujitsu.com
State New
Headers show
Series [1/5,meta-python] python3-socketio: upgrade 5.5.0 -> 5.5.1 | expand

Commit Message

XU Huan Jan. 20, 2022, 7:22 a.m. UTC
From: Xu Huan <xuhuan.fnst@fujitsu.com>

Signed-off-by: Xu Huan <xuhuan.fnst@fujitsu.com>
---
 .../python/python3-async-timeout_4.0.2.bb      | 18 ++++++++++++++++++
 1 file changed, 18 insertions(+)
 create mode 100644 meta-python/recipes-devtools/python/python3-async-timeout_4.0.2.bb

Patch

diff --git a/meta-python/recipes-devtools/python/python3-async-timeout_4.0.2.bb b/meta-python/recipes-devtools/python/python3-async-timeout_4.0.2.bb
new file mode 100644
index 0000000000..7355f00131
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-async-timeout_4.0.2.bb
@@ -0,0 +1,18 @@ 
+SUMMARY = "asyncio-compatible timeout context manager"
+DESCRIPTION = "\
+The context manager is useful in cases when you want to apply \
+timeout logic around block of code or in cases when asyncio.wait_for() \
+is not suitable. Also it's much faster than asyncio.wait_for() because \
+timeout doesn't create a new task."
+HOMEPAGE = "https://github.com/aio-libs/async-timeout"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=4fa41f15bb5f23b6d3560c5845eb8d57"
+
+SRC_URI[sha256sum] = "2163e1640ddb52b7a8c80d0a67a08587e5d245cc9c553a74a847056bc2976b15"
+
+PYPI_PACKAGE = "async-timeout"
+inherit pypi setuptools3
+
+RDEPENDS:${PN} = "\
+    ${PYTHON_PN}-asyncio \
+"