[meta-python] python3-pandas: upgrade 1.3.4 -> 1.3.5

Message ID 1641462745-19071-2-git-send-email-xuhuan.fnst@fujitsu.com
State New
Headers show
Series [meta-python] python3-pandas: upgrade 1.3.4 -> 1.3.5 | expand

Commit Message

XU Huan Jan. 6, 2022, 9:52 a.m. UTC
From: Xu Huan <xuhuan.fnst@fujitsu.com>

changelog:
===============================================================================

-Fixed regression in Series.equals() when comparing floats with dtype object to
None (GH44190)
-Fixed regression in merge_asof() raising error when array was supplied as join
key (GH42844)
-Fixed regression when resampling DataFrame with DateTimeIndex with empty groups
and uint8, uint16 or uint32 columns incorrectly raising RuntimeError (GH43329)
-Fixed regression in creating a DataFrame from a timezone-aware Timestamp scalar
near a Daylight Savings Time transition (GH42505)
-Fixed performance regression in read_csv() (GH44106)
-Fixed regression in Series.duplicated() and Series.drop_duplicates() when Series
has Categorical dtype with boolean categories (GH44351)
-Fixed regression in GroupBy.sum() with timedelta64[ns] dtype containing NaT
failing to treat that value as NA (GH42659)
-Fixed regression in RollingGroupby.cov() and RollingGroupby.corr() when other
had the same shape as each group would incorrectly return superfluous groups
in the result (GH42915)

Signed-off-by: Xu Huan <xuhuan.fnst@fujitsu.com>
---
 .../python/{python3-pandas_1.3.4.bb => python3-pandas_1.3.5.bb} | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta-python/recipes-devtools/python/{python3-pandas_1.3.4.bb => python3-pandas_1.3.5.bb} (89%)

Patch

diff --git a/meta-python/recipes-devtools/python/python3-pandas_1.3.4.bb b/meta-python/recipes-devtools/python/python3-pandas_1.3.5.bb
similarity index 89%
rename from meta-python/recipes-devtools/python/python3-pandas_1.3.4.bb
rename to meta-python/recipes-devtools/python/python3-pandas_1.3.5.bb
index cde43184bb..2547875395 100644
--- a/meta-python/recipes-devtools/python/python3-pandas_1.3.4.bb
+++ b/meta-python/recipes-devtools/python/python3-pandas_1.3.5.bb
@@ -6,7 +6,7 @@  HOMEPAGE = "http://pandas.pydata.org/"
 LICENSE = "BSD-3-Clause"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=3f23c5c092b74d245d48eeef72bc3fd2"
 
-SRC_URI[sha256sum] = "a2aa18d3f0b7d538e21932f637fbfe8518d085238b429e4790a35e1e44a96ffc"
+SRC_URI[sha256sum] = "1e4285f5de1012de20ca46b188ccf33521bff61ba5c5ebd78b4fb28e5416a9f1"
 
 inherit pypi setuptools3