[meta-python] python3-pycparser: upgrade 2.20 -> 2.21

Message ID 1638508918-22365-1-git-send-email-xuhuan.fnst@fujitsu.com
State New
Headers show
Series [meta-python] python3-pycparser: upgrade 2.20 -> 2.21 | expand

Commit Message

XU Huan Dec. 3, 2021, 5:21 a.m. UTC
From: Xu Huan <xuhuan.fnst@fujitsu.com>

changelog:
=================================================================
  - Much improved support for C11 (multiple PRs)
  - Support for parehthesized compount statements
  - Support for modern Python versions (3.9 and 3.10)
  - Fix support for structs with nested enums
  - Multiple small bug fixes

Signed-off-by: Xu Huan <xuhuan.fnst@fujitsu.com>
---
 ...{python3-pycparser_2.20.bb => python3-pycparser_2.21.bb} | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)
 rename meta-python/recipes-devtools/python/{python3-pycparser_2.20.bb => python3-pycparser_2.21.bb} (64%)

Comments

Khem Raj Dec. 3, 2021, 6:36 a.m. UTC | #1
On Thu, Dec 2, 2021 at 9:22 PM xuhuan.fnst@fujitsu.com
<xuhuan.fnst@fujitsu.com> wrote:
>
> From: Xu Huan <xuhuan.fnst@fujitsu.com>
>
> changelog:
> =================================================================
>   - Much improved support for C11 (multiple PRs)
>   - Support for parehthesized compount statements
>   - Support for modern Python versions (3.9 and 3.10)
>   - Fix support for structs with nested enums
>   - Multiple small bug fixes
>
> Signed-off-by: Xu Huan <xuhuan.fnst@fujitsu.com>
> ---
>  ...{python3-pycparser_2.20.bb => python3-pycparser_2.21.bb} | 6 +++---
>  1 file changed, 3 insertions(+), 3 deletions(-)
>  rename meta-python/recipes-devtools/python/{python3-pycparser_2.20.bb => python3-pycparser_2.21.bb} (64%)
>
> diff --git a/meta-python/recipes-devtools/python/python3-pycparser_2.20.bb b/meta-python/recipes-devtools/python/python3-pycparser_2.21.bb
> similarity index 64%
> rename from meta-python/recipes-devtools/python/python3-pycparser_2.20.bb
> rename to meta-python/recipes-devtools/python/python3-pycparser_2.21.bb
> index fde868a701..3b8a9cd206 100644
> --- a/meta-python/recipes-devtools/python/python3-pycparser_2.20.bb
> +++ b/meta-python/recipes-devtools/python/python3-pycparser_2.21.bb
> @@ -1,10 +1,10 @@
>  SUMMARY = "Parser of the C language, written in pure Python"
>  HOMEPAGE = "https://github.com/eliben/pycparser"
>  LICENSE = "BSD-3-Clause"
> -LIC_FILES_CHKSUM = "file://LICENSE;md5=86f1cedb4e6410a88ce8e30b91079169"
> +LIC_FILES_CHKSUM = "file://LICENSE;md5=2c28cdeabcb88f5843d934381b4b4fea"

why did this checksum change ? can you add that to commit msg via
"License-Update" tag ?

>
> -SRC_URI[md5sum] = "b8f88de737db8c346ee8d31c07c7a25a"
> -SRC_URI[sha256sum] = "2d475327684562c3a96cc71adf7dc8c4f0565175cf86b6d7a404ff4c771f15f0"
> +SRC_URI[md5sum] = "48f7d743bf018f7bb2ffc5fb976d1492"
> +SRC_URI[sha256sum] = "e644fdec12f7872f86c58ff790da456218b10f863970249516d60a5eaca77206"
>
>  inherit pypi setuptools3
>
> --
> 2.25.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#94190): https://lists.openembedded.org/g/openembedded-devel/message/94190
> Mute This Topic: https://lists.openembedded.org/mt/87471515/1997914
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>

Patch

diff --git a/meta-python/recipes-devtools/python/python3-pycparser_2.20.bb b/meta-python/recipes-devtools/python/python3-pycparser_2.21.bb
similarity index 64%
rename from meta-python/recipes-devtools/python/python3-pycparser_2.20.bb
rename to meta-python/recipes-devtools/python/python3-pycparser_2.21.bb
index fde868a701..3b8a9cd206 100644
--- a/meta-python/recipes-devtools/python/python3-pycparser_2.20.bb
+++ b/meta-python/recipes-devtools/python/python3-pycparser_2.21.bb
@@ -1,10 +1,10 @@ 
 SUMMARY = "Parser of the C language, written in pure Python"
 HOMEPAGE = "https://github.com/eliben/pycparser"
 LICENSE = "BSD-3-Clause"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=86f1cedb4e6410a88ce8e30b91079169"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=2c28cdeabcb88f5843d934381b4b4fea"
 
-SRC_URI[md5sum] = "b8f88de737db8c346ee8d31c07c7a25a"
-SRC_URI[sha256sum] = "2d475327684562c3a96cc71adf7dc8c4f0565175cf86b6d7a404ff4c771f15f0"
+SRC_URI[md5sum] = "48f7d743bf018f7bb2ffc5fb976d1492"
+SRC_URI[sha256sum] = "e644fdec12f7872f86c58ff790da456218b10f863970249516d60a5eaca77206"
 
 inherit pypi setuptools3