diff mbox series

[kirkstone,08/10] cve-update-nvd2-native: always pass str for json.loads()

Message ID e67d659847afe648de1b1eca2d19c4f6375dd12c.1691071255.git.steve@sakoman.com
State Accepted, archived
Commit e67d659847afe648de1b1eca2d19c4f6375dd12c
Headers show
Series [kirkstone,01/10] libpcre2: patch CVE-2022-41409 | expand

Commit Message

Steve Sakoman Aug. 3, 2023, 2:04 p.m. UTC
From: Yuta Hayama <hayama@lineo.co.jp>

Currently json.loads() accepts one of the types str, bytes, or bytearray
as an argument, but bytes and bytearrays have only been allowed since
python 3.6. The version of Python3 provided by default on Ubuntu 16.04
and Debian 9.x is 3.5, so make raw_data type str to work correctly on
these build hosts.

Signed-off-by: Yuta Hayama <hayama@lineo.co.jp>
Signed-off-by: Steve Sakoman <steve@sakoman.com>
---
 meta/recipes-core/meta/cve-update-nvd2-native.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/meta/recipes-core/meta/cve-update-nvd2-native.bb b/meta/recipes-core/meta/cve-update-nvd2-native.bb
index 2f7dad7e82..67d76f75dd 100644
--- a/meta/recipes-core/meta/cve-update-nvd2-native.bb
+++ b/meta/recipes-core/meta/cve-update-nvd2-native.bb
@@ -136,7 +136,7 @@  def nvd_request_next(url, api_key, args):
 
             if (r.headers['content-encoding'] == 'gzip'):
                 buf = r.read()
-                raw_data = gzip.decompress(buf)
+                raw_data = gzip.decompress(buf).decode("utf-8")
             else:
                 raw_data = r.read().decode("utf-8")