diff mbox series

[5/5] python3-wheel: upgrade 0.38.4 -> 0.40.0

Message ID de64dd5a8194c9c7e4a99cdc93ddab3841a6d33e.1678928363.git.tim.orling@konsulko.com
State Accepted, archived
Commit d88ec936065f45851dd2a15bd8549c75e7746c75
Headers show
Series [1/5] python3-pytest: upgrade 7.2.1 -> 7.2.2 | expand

Commit Message

Tim Orling March 16, 2023, 1:03 a.m. UTC
* Drop pyproject.toml patch, merged upstream

https://wheel.readthedocs.io/en/stable/news.html#release-notes

0.40.0 (2023-03-14)
* Added a wheel tags command to modify tags on an existing wheel (PR by
  Henry Schreiner)
* Updated vendored packaging to 23.0
* wheel unpack now preserves the executable attribute of extracted files
* Fixed spaces in platform names not being converted to underscores (PR
  by David Tucker)
* Fixed RECORD files in generated wheels missing the regular file attribute
* Fixed DeprecationWarning about the use of the deprecated pkg_resources
  API (PR by Thomas Grainger)
* Wheel now uses flit-core as a build backend (PR by Henry Schreiner)

License-Update: use LICENSE.txt for LIC_FILES_CHKSUM instead of PKG-INFO

Signed-off-by: Tim Orling <tim.orling@konsulko.com>
---
 ...roject.toml-from-flit-backend-branch.patch | 100 ------------------
 ...heel_0.38.4.bb => python3-wheel_0.40.0.bb} |   6 +-
 2 files changed, 2 insertions(+), 104 deletions(-)
 delete mode 100644 meta/recipes-devtools/python/python3-wheel/0001-Backport-pyproject.toml-from-flit-backend-branch.patch
 rename meta/recipes-devtools/python/{python3-wheel_0.38.4.bb => python3-wheel_0.40.0.bb} (62%)

Comments

Alexandre Belloni March 16, 2023, 8:04 a.m. UTC | #1
On 15/03/2023 18:03:01-0700, Tim Orling wrote:
> Content-Type: text/plain; charset=y

You replied 'y' to the encoding question where you should have been more
careful and simply press enter ;) (and so the patch doesn't apply
without manually editing it)

> Content-Transfer-Encoding: 8bit

> * Drop pyproject.toml patch, merged upstream
> 
> https://wheel.readthedocs.io/en/stable/news.html#release-notes
> 
> 0.40.0 (2023-03-14)
> * Added a wheel tags command to modify tags on an existing wheel (PR by
>   Henry Schreiner)
> * Updated vendored packaging to 23.0
> * wheel unpack now preserves the executable attribute of extracted files
> * Fixed spaces in platform names not being converted to underscores (PR
>   by David Tucker)
> * Fixed RECORD files in generated wheels missing the regular file attribute
> * Fixed DeprecationWarning about the use of the deprecated pkg_resources
>   API (PR by Thomas Grainger)
> * Wheel now uses flit-core as a build backend (PR by Henry Schreiner)
> 
> License-Update: use LICENSE.txt for LIC_FILES_CHKSUM instead of PKG-INFO
> 
> Signed-off-by: Tim Orling <tim.orling@konsulko.com>
> ---
>  ...roject.toml-from-flit-backend-branch.patch | 100 ------------------
>  ...heel_0.38.4.bb => python3-wheel_0.40.0.bb} |   6 +-
>  2 files changed, 2 insertions(+), 104 deletions(-)
>  delete mode 100644 meta/recipes-devtools/python/python3-wheel/0001-Backport-pyproject.toml-from-flit-backend-branch.patch
>  rename meta/recipes-devtools/python/{python3-wheel_0.38.4.bb => python3-wheel_0.40.0.bb} (62%)
> 
> diff --git a/meta/recipes-devtools/python/python3-wheel/0001-Backport-pyproject.toml-from-flit-backend-branch.patch b/meta/recipes-devtools/python/python3-wheel/0001-Backport-pyproject.toml-from-flit-backend-branch.patch
> deleted file mode 100644
> index 023de0e6a88..00000000000
> --- a/meta/recipes-devtools/python/python3-wheel/0001-Backport-pyproject.toml-from-flit-backend-branch.patch
> +++ /dev/null
> @@ -1,100 +0,0 @@
> -From f00dd220346773bc088d403847ee7f06f2b4c30a Mon Sep 17 00:00:00 2001
> -From: Tim Orling <tim.orling@konsulko.com>
> -Date: Fri, 18 Feb 2022 11:09:16 -0800
> -Subject: [PATCH] Backport pyproject.toml from flit-backend branch
> -
> -This allows us to bootstrap wheels and PEP-517 packaging.
> -
> -Upstream-Status: Backport from flit-backend branch
> -https://raw.githubusercontent.com/pypa/wheel/4f6ba78fede38a8d9e35a14e38377a121033afb3/pyproject.toml
> -
> -Signed-off-by: Tim Orling <tim.orling@konsulko.com>
> ----
> - pyproject.toml | 78 ++++++++++++++++++++++++++++++++++++++++++++++++++
> - 1 file changed, 78 insertions(+)
> - create mode 100644 pyproject.toml
> -
> -diff --git a/pyproject.toml b/pyproject.toml
> -new file mode 100644
> -index 0000000..749b8de
> ---- /dev/null
> -+++ b/pyproject.toml
> -@@ -0,0 +1,78 @@
> -+[build-system]
> -+requires = ["flit_core >=3.2,<4"]
> -+build-backend = "flit_core.buildapi"
> -+
> -+[project]
> -+name = "wheel"
> -+description = "A built-package format for Python"
> -+readme = "README.rst"
> -+classifiers = [
> -+    "Development Status :: 5 - Production/Stable",
> -+    "Intended Audience :: Developers",
> -+    "Topic :: System :: Archiving :: Packaging",
> -+    "License :: OSI Approved :: MIT License",
> -+    "Programming Language :: Python",
> -+    "Programming Language :: Python :: 3 :: Only",
> -+    "Programming Language :: Python :: 3.7",
> -+    "Programming Language :: Python :: 3.8",
> -+    "Programming Language :: Python :: 3.9",
> -+    "Programming Language :: Python :: 3.10"
> -+]
> -+authors = [{name = "Daniel Holth", email = "dholth@fastmail.fm"}]
> -+maintainers = [{name = "Alex Gr�nholm", email = "alex.gronholm@nextday.fi"}]
> -+keywords = ["wheel", "packaging"]
> -+license = {file = "LICENSE.txt"}
> -+requires-python = ">=3.7"
> -+dependencies = [
> -+    "setuptools >= 45.2.0"
> -+]
> -+dynamic = ["version"]
> -+
> -+[project.urls]
> -+Documentation = "https://wheel.readthedocs.io/"
> -+Changelog = "https://wheel.readthedocs.io/en/stable/news.html"
> -+"Issue Tracker" = "https://github.com/pypa/wheel/issues"
> -+
> -+[project.scripts]
> -+wheel = "wheel.cli:main"
> -+
> -+[project.entry-points."distutils.commands"]
> -+bdist_wheel = "wheel.bdist_wheel:bdist_wheel"
> -+
> -+[project.optional-dependencies]
> -+test = [
> -+    "pytest >= 3.0.0"
> -+]
> -+
> -+[tool.flit.sdist]
> -+exclude = [
> -+    ".cirrus.yml",
> -+    ".github/*",
> -+    ".gitignore",
> -+    ".pre-commit-config.yaml",
> -+    ".readthedocs.yml"
> -+]
> -+
> -+[tool.black]
> -+target-version = ['py37']
> -+extend-exclude = '''
> -+^/src/wheel/vendored/
> -+'''
> -+
> -+[tool.isort]
> -+src_paths = ["src"]
> -+profile = "black"
> -+skip_gitignore = true
> -+
> -+[tool.flake8]
> -+max-line-length = 88
> -+
> -+[tool.pytest.ini_options]
> -+testpaths = "tests"
> -+
> -+[tool.coverage.run]
> -+source = ["wheel"]
> -+omit = ["*/vendored/*"]
> -+
> -+[tool.coverage.report]
> -+show_missing = true
> diff --git a/meta/recipes-devtools/python/python3-wheel_0.38.4.bb b/meta/recipes-devtools/python/python3-wheel_0.40.0.bb
> similarity index 62%
> rename from meta/recipes-devtools/python/python3-wheel_0.38.4.bb
> rename to meta/recipes-devtools/python/python3-wheel_0.40.0.bb
> index 6263cbc45c7..2b8111d544b 100644
> --- a/meta/recipes-devtools/python/python3-wheel_0.38.4.bb
> +++ b/meta/recipes-devtools/python/python3-wheel_0.40.0.bb
> @@ -2,14 +2,12 @@ SUMMARY = "The official binary distribution format for Python "
>  HOMEPAGE = "https://github.com/pypa/wheel"
>  SECTION = "devel/python"
>  LICENSE = "MIT"
> -LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=10;endline=10;md5=8227180126797a0148f94f483f3e1489"
> +LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=7ffb0db04527cfe380e4f2726bd05ebf"
>  
> -SRC_URI[sha256sum] = "965f5259b566725405b05e7cf774052044b1ed30119b5d586b2703aafe8719ac"
> +SRC_URI[sha256sum] = "cd1196f3faee2b31968d626e1731c94f99cbdb67cf5a46e4f5656cbee7738873"
>  
>  inherit python_flit_core pypi
>  
> -SRC_URI += " file://0001-Backport-pyproject.toml-from-flit-backend-branch.patch"
> -
>  BBCLASSEXTEND = "native nativesdk"
>  
>  # This used to use the bootstrap install which didn't compile. Until we bump the
> -- 
> 2.30.2
> 

> 
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#178670): https://lists.openembedded.org/g/openembedded-core/message/178670
> Mute This Topic: https://lists.openembedded.org/mt/97641809/3617179
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [alexandre.belloni@bootlin.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
diff mbox series

Patch

diff --git a/meta/recipes-devtools/python/python3-wheel/0001-Backport-pyproject.toml-from-flit-backend-branch.patch b/meta/recipes-devtools/python/python3-wheel/0001-Backport-pyproject.toml-from-flit-backend-branch.patch
deleted file mode 100644
index 023de0e6a88..00000000000
--- a/meta/recipes-devtools/python/python3-wheel/0001-Backport-pyproject.toml-from-flit-backend-branch.patch
+++ /dev/null
@@ -1,100 +0,0 @@ 
-From f00dd220346773bc088d403847ee7f06f2b4c30a Mon Sep 17 00:00:00 2001
-From: Tim Orling <tim.orling@konsulko.com>
-Date: Fri, 18 Feb 2022 11:09:16 -0800
-Subject: [PATCH] Backport pyproject.toml from flit-backend branch
-
-This allows us to bootstrap wheels and PEP-517 packaging.
-
-Upstream-Status: Backport from flit-backend branch
-https://raw.githubusercontent.com/pypa/wheel/4f6ba78fede38a8d9e35a14e38377a121033afb3/pyproject.toml
-
-Signed-off-by: Tim Orling <tim.orling@konsulko.com>
----
- pyproject.toml | 78 ++++++++++++++++++++++++++++++++++++++++++++++++++
- 1 file changed, 78 insertions(+)
- create mode 100644 pyproject.toml
-
-diff --git a/pyproject.toml b/pyproject.toml
-new file mode 100644
-index 0000000..749b8de
---- /dev/null
-+++ b/pyproject.toml
-@@ -0,0 +1,78 @@
-+[build-system]
-+requires = ["flit_core >=3.2,<4"]
-+build-backend = "flit_core.buildapi"
-+
-+[project]
-+name = "wheel"
-+description = "A built-package format for Python"
-+readme = "README.rst"
-+classifiers = [
-+    "Development Status :: 5 - Production/Stable",
-+    "Intended Audience :: Developers",
-+    "Topic :: System :: Archiving :: Packaging",
-+    "License :: OSI Approved :: MIT License",
-+    "Programming Language :: Python",
-+    "Programming Language :: Python :: 3 :: Only",
-+    "Programming Language :: Python :: 3.7",
-+    "Programming Language :: Python :: 3.8",
-+    "Programming Language :: Python :: 3.9",
-+    "Programming Language :: Python :: 3.10"
-+]
-+authors = [{name = "Daniel Holth", email = "dholth@fastmail.fm"}]
-+maintainers = [{name = "Alex Grönholm", email = "alex.gronholm@nextday.fi"}]
-+keywords = ["wheel", "packaging"]
-+license = {file = "LICENSE.txt"}
-+requires-python = ">=3.7"
-+dependencies = [
-+    "setuptools >= 45.2.0"
-+]
-+dynamic = ["version"]
-+
-+[project.urls]
-+Documentation = "https://wheel.readthedocs.io/"
-+Changelog = "https://wheel.readthedocs.io/en/stable/news.html"
-+"Issue Tracker" = "https://github.com/pypa/wheel/issues"
-+
-+[project.scripts]
-+wheel = "wheel.cli:main"
-+
-+[project.entry-points."distutils.commands"]
-+bdist_wheel = "wheel.bdist_wheel:bdist_wheel"
-+
-+[project.optional-dependencies]
-+test = [
-+    "pytest >= 3.0.0"
-+]
-+
-+[tool.flit.sdist]
-+exclude = [
-+    ".cirrus.yml",
-+    ".github/*",
-+    ".gitignore",
-+    ".pre-commit-config.yaml",
-+    ".readthedocs.yml"
-+]
-+
-+[tool.black]
-+target-version = ['py37']
-+extend-exclude = '''
-+^/src/wheel/vendored/
-+'''
-+
-+[tool.isort]
-+src_paths = ["src"]
-+profile = "black"
-+skip_gitignore = true
-+
-+[tool.flake8]
-+max-line-length = 88
-+
-+[tool.pytest.ini_options]
-+testpaths = "tests"
-+
-+[tool.coverage.run]
-+source = ["wheel"]
-+omit = ["*/vendored/*"]
-+
-+[tool.coverage.report]
-+show_missing = true
diff --git a/meta/recipes-devtools/python/python3-wheel_0.38.4.bb b/meta/recipes-devtools/python/python3-wheel_0.40.0.bb
similarity index 62%
rename from meta/recipes-devtools/python/python3-wheel_0.38.4.bb
rename to meta/recipes-devtools/python/python3-wheel_0.40.0.bb
index 6263cbc45c7..2b8111d544b 100644
--- a/meta/recipes-devtools/python/python3-wheel_0.38.4.bb
+++ b/meta/recipes-devtools/python/python3-wheel_0.40.0.bb
@@ -2,14 +2,12 @@  SUMMARY = "The official binary distribution format for Python "
 HOMEPAGE = "https://github.com/pypa/wheel"
 SECTION = "devel/python"
 LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=10;endline=10;md5=8227180126797a0148f94f483f3e1489"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=7ffb0db04527cfe380e4f2726bd05ebf"
 
-SRC_URI[sha256sum] = "965f5259b566725405b05e7cf774052044b1ed30119b5d586b2703aafe8719ac"
+SRC_URI[sha256sum] = "cd1196f3faee2b31968d626e1731c94f99cbdb67cf5a46e4f5656cbee7738873"
 
 inherit python_flit_core pypi
 
-SRC_URI += " file://0001-Backport-pyproject.toml-from-flit-backend-branch.patch"
-
 BBCLASSEXTEND = "native nativesdk"
 
 # This used to use the bootstrap install which didn't compile. Until we bump the