setuptools_build_meta: remove python dependency

Message ID AM9PR09MB4642A02EF7369BEC6B3EFE27A8069@AM9PR09MB4642.eurprd09.prod.outlook.com
State Accepted, archived
Commit bd9f9a369160164beade2c12f344b7f5c2b18427
Headers show
Series setuptools_build_meta: remove python dependency | expand

Commit Message

Konrad Weihmann March 5, 2022, 11:16 a.m. UTC
when building additional native python tools that should be used
for additional tasks in python3 package (class-target), the dependency
on target class python creates a dependency loop:

python3-foo-native_1.2.3.bb:do_prepare_recipe_sysroot
python3-pep8-native_1.7.1.bb:do_populate_sysroot
python3-wheel_0.37.1.bb:do_populate_sysroot
python3-bar-native_0.1.2.bb:do_populate_sysroot
python3-pip_22.0.3.bb:do_populate_sysroot
python3-pyflakes-native_2.4.0.bb:do_populate_sysroot
python3_3.10.2.bb:do_populate_sysroot
python3-foo-native_1.2.3_1.2.0.bb:do_fetch
python3-setuptools_59.5.0.bb:do_populate_sysroot

resolve this by removing python3 from DEPENDS.
The correct dependencies are already injected by
setuptools-base class

Signed-off-by: Konrad Weihmann <kweihmann@outlook.com>
---
 meta/classes/setuptools_build_meta.bbclass | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Patch

diff --git a/meta/classes/setuptools_build_meta.bbclass b/meta/classes/setuptools_build_meta.bbclass
index b1441e65dd..8f5479e922 100644
--- a/meta/classes/setuptools_build_meta.bbclass
+++ b/meta/classes/setuptools_build_meta.bbclass
@@ -1,6 +1,6 @@ 
 inherit pip_install_wheel setuptools3-base
 
-DEPENDS += "python3 python3-setuptools-native python3-wheel-native"
+DEPENDS += "python3-setuptools-native python3-wheel-native"
 
 setuptools_build_meta_do_configure () {
     mkdir -p ${S}/dist