gmp: fix EXTRA_OECONF for mipsarchr6

Message ID AM9PR09MB464241300636B9ED5F4BFF23A8349@AM9PR09MB4642.eurprd09.prod.outlook.com
State Accepted, archived
Commit c17e1023eff86e71734edeb592a26f3a9160d72e
Headers show
Series gmp: fix EXTRA_OECONF for mipsarchr6 | expand

Commit Message

Konrad Weihmann Feb. 15, 2022, 12:41 p.m. UTC
previously used mipsarchr6:append created an empty set for
EXTRA_OECONF and then appended --disable-assembly
while it should be just added to the existing var value.
Without this patch gmp will be configured without
--enable-cxx=detect for mipsarchr6 targets

Signed-off-by: Konrad Weihmann <kweihmann@outlook.com>
---
 meta/recipes-support/gmp/gmp_6.2.1.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Khem Raj Feb. 15, 2022, 4:26 p.m. UTC | #1
On Tue, Feb 15, 2022 at 4:41 AM Konrad Weihmann <kweihmann@outlook.com> wrote:
>
> previously used mipsarchr6:append created an empty set for
> EXTRA_OECONF and then appended --disable-assembly
> while it should be just added to the existing var value.
> Without this patch gmp will be configured without
> --enable-cxx=detect for mipsarchr6 targets
>
> Signed-off-by: Konrad Weihmann <kweihmann@outlook.com>
> ---
>  meta/recipes-support/gmp/gmp_6.2.1.bb | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/meta/recipes-support/gmp/gmp_6.2.1.bb b/meta/recipes-support/gmp/gmp_6.2.1.bb
> index e61582afdf..33f439eca9 100644
> --- a/meta/recipes-support/gmp/gmp_6.2.1.bb
> +++ b/meta/recipes-support/gmp/gmp_6.2.1.bb
> @@ -20,7 +20,7 @@ SRC_URI[sha256sum] = "eae9326beb4158c386e39a356818031bd28f3124cf915f8c5b1dc4c7a3
>  acpaths = ""
>
>  EXTRA_OECONF += " --enable-cxx=detect"
> -EXTRA_OECONF:mipsarchr6:append = " --disable-assembly"
> +EXTRA_OECONF:append:mipsarchr6 = " --disable-assembly"

yes the keywords were wrongly arranged. Thanks for fixing it.

>
>  PACKAGES =+ "libgmpxx"
>  FILES:libgmpxx = "${libdir}/libgmpxx${SOLIBS}"
> --
> 2.25.1
>

Patch

diff --git a/meta/recipes-support/gmp/gmp_6.2.1.bb b/meta/recipes-support/gmp/gmp_6.2.1.bb
index e61582afdf..33f439eca9 100644
--- a/meta/recipes-support/gmp/gmp_6.2.1.bb
+++ b/meta/recipes-support/gmp/gmp_6.2.1.bb
@@ -20,7 +20,7 @@  SRC_URI[sha256sum] = "eae9326beb4158c386e39a356818031bd28f3124cf915f8c5b1dc4c7a3
 acpaths = ""
 
 EXTRA_OECONF += " --enable-cxx=detect"
-EXTRA_OECONF:mipsarchr6:append = " --disable-assembly"
+EXTRA_OECONF:append:mipsarchr6 = " --disable-assembly"
 
 PACKAGES =+ "libgmpxx"
 FILES:libgmpxx = "${libdir}/libgmpxx${SOLIBS}"