diff mbox series

[1/4] python3-more-itertools: upgrade 9.0.0 -> 9.1.0

Message ID 895d4baa2de54ed384821e87918b3f8493d7c11f.1677693991.git.tim.orling@konsulko.com
State Accepted, archived
Commit 436b92846406273fb3651f4f026e9fd3871ee71c
Headers show
Series [1/4] python3-more-itertools: upgrade 9.0.0 -> 9.1.0 | expand

Commit Message

Tim Orling March 1, 2023, 6:10 p.m. UTC
Upstream docs currently have a typo showing the changes as 8.14.0
https://github.com/more-itertools/more-itertools/commit/89d58c2ec089f3df54ed6cc9279949b8e2bbcd29

9.1.0
-----
* New functions
  - iter_index() (from the Python itertools docs)
  - transpose() (from the Python itertools docs)
  - matmul() (from the Python itertools docs)
  - factor() (from the Python itertools docs)
  - gray_product() (thanks to haukex)
* Changes to existing functions
  - sieve() was updated to match the Python itertools docs
  - maxsplit() was updated to fix a bug (thanks to abingham)
  - sliced() had its type hint updated (thanks to ad-chaos)
* Other changes
  - The batched function is marked as deprecated and will be removed in a
    future major release. For Python 3.12 and above, use itertools.batched
    instead. (thanks to neutrinoceros)
  - The type hints now used postponed evaluation of annotations from PEP 563
    (thanks to Isira-Seneviratne)
  - Some documentation issues were fixed (thanks to Voskov and jdkandersson)

Signed-off-by: Tim Orling <tim.orling@konsulko.com>
---
All ptests pass on qemux86-64

 ...-more-itertools_9.0.0.bb => python3-more-itertools_9.1.0.bb} | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta/recipes-devtools/python/{python3-more-itertools_9.0.0.bb => python3-more-itertools_9.1.0.bb} (86%)
diff mbox series

Patch

diff --git a/meta/recipes-devtools/python/python3-more-itertools_9.0.0.bb b/meta/recipes-devtools/python/python3-more-itertools_9.1.0.bb
similarity index 86%
rename from meta/recipes-devtools/python/python3-more-itertools_9.0.0.bb
rename to meta/recipes-devtools/python/python3-more-itertools_9.1.0.bb
index fce3aea8977..7602350795f 100644
--- a/meta/recipes-devtools/python/python3-more-itertools_9.0.0.bb
+++ b/meta/recipes-devtools/python/python3-more-itertools_9.1.0.bb
@@ -3,7 +3,7 @@  HOMEPAGE = "https://github.com/erikrose/more-itertools"
 LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=3396ea30f9d21389d7857719816f83b5"
 
-SRC_URI[sha256sum] = "5a6257e40878ef0520b1803990e3e22303a41b5714006c32a3fd8304b26ea1ab"
+SRC_URI[sha256sum] = "cabaa341ad0389ea83c17a94566a53ae4c9d07349861ecb14dc6d0345cf9ac5d"
 
 inherit pypi python_flit_core ptest