diff mbox series

[2/7] python3-maturin: bzip2-sys reproduciblility

Message ID 8803dc101b641c948805cab9e5784c38f43b0e51.1702791173.git.tim.orling@konsulko.com
State Accepted, archived
Commit 58a4f8b3afb67e6818f544e74a7f1dd2b1a66f86
Headers show
Series [1/7] python3-maturin: add v1.4.0 | expand

Commit Message

Tim Orling Dec. 17, 2023, 5:41 a.m. UTC
The /usr/bin/.debug/maturin binary ends up with the path
to the bzip-sys (bzip2-1.0.8) source in the python3-maturin-dbg package

Fix this by mapping the debug path for CARGO_HOME
to TARGET_DBGSRC_DIR/cargo_home via CFLAGS. This is
required because the bzip-sys crate is compiled using
the cc crate and we override default CFLAGS.

Signed-off-by: Tim Orling <tim.orling@konsulko.com>
---
 meta/recipes-devtools/python/python3-maturin_1.4.0.bb | 2 ++
 1 file changed, 2 insertions(+)
diff mbox series

Patch

diff --git a/meta/recipes-devtools/python/python3-maturin_1.4.0.bb b/meta/recipes-devtools/python/python3-maturin_1.4.0.bb
index 6f7cc6ef397..07ad1201b89 100644
--- a/meta/recipes-devtools/python/python3-maturin_1.4.0.bb
+++ b/meta/recipes-devtools/python/python3-maturin_1.4.0.bb
@@ -9,6 +9,8 @@  SRC_URI[sha256sum] = "ed12e1768094a7adeafc3a74ebdb8dc2201fa64c4e7e31f14cfc70378b
 
 S = "${WORKDIR}/maturin-${PV}"
 
+CFLAGS:append = "-fdebug-prefix-map=${CARGO_HOME}=${TARGET_DBGSRC_DIR}/cargo_home"
+
 DEPENDS += "\
     python3-setuptools-rust-native \
     python3-semantic-version-native \