[hardknott,9/9] python3-pyelftools: fix the override syntax

Message ID 7e569186820163d731cbb14f8c25ce6a2cc45dc9.1641911316.git.anuj.mittal@intel.com
State Accepted, archived
Commit 7e569186820163d731cbb14f8c25ce6a2cc45dc9
Headers show
Series [hardknott,1/9] webkitgtk: fix fix CVE-2021-42762 | expand

Commit Message

Mittal, Anuj Jan. 11, 2022, 2:32 p.m. UTC
An earlier patch cherry-picked from master used : for override. Change
it to use _ for hardknott.

Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
---
 meta/recipes-devtools/python/python3-pyelftools_0.27.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Chuck Wolber Jan. 11, 2022, 3:43 p.m. UTC | #1
On Tue, Jan 11, 2022 at 06:33 Anuj Mittal <anuj.mittal@intel.com> wrote:

> An earlier patch cherry-picked from master used : for override. Change
> it to use _ for hardknott.


I have been using the “:” for override in Hardknott for some time now. Why
is this being reverted?

..Ch:W..
Mittal, Anuj Jan. 12, 2022, 2:17 a.m. UTC | #2
On Tue, 2022-01-11 at 07:43 -0800, Chuck Wolber wrote:
> On Tue, Jan 11, 2022 at 06:33 Anuj Mittal <anuj.mittal@intel.com>
> wrote:
> > An earlier patch cherry-picked from master used : for override.
> > Change
> > it to use _ for hardknott.
> > 
> 
> 
> I have been using the “:” for override in Hardknott for some time
> now. Why is this being reverted?
> 

You can use both if you have bitbake updated to use latest
hardknott/1.50. Hardknott used _ at the time of release and using :
would give an error when using an older bitbake on hardknott that
didn't recognize :.

Thanks,

Anuj

Patch

diff --git a/meta/recipes-devtools/python/python3-pyelftools_0.27.bb b/meta/recipes-devtools/python/python3-pyelftools_0.27.bb
index e2d0e18277..f8b9d420a5 100644
--- a/meta/recipes-devtools/python/python3-pyelftools_0.27.bb
+++ b/meta/recipes-devtools/python/python3-pyelftools_0.27.bb
@@ -12,4 +12,4 @@  inherit pypi setuptools3
 
 BBCLASSEXTEND = "native"
 
-RDEPENDS:${PN} += "${PYTHON_PN}-debugger ${PYTHON_PN}-pprint"
+RDEPENDS_${PN} += "${PYTHON_PN}-debugger ${PYTHON_PN}-pprint"