diff mbox series

[v2] libtirpc: Support ipv6 in DISTRO_FEATURES

Message ID 64a7ca1412df4f236a8416ef4d3c0f1dc3208d1d.1697122532.git.joerg.sommer@navimatix.de
State Accepted, archived
Commit f1109380a4fec02dba0b5bd50c77b4825faa20a2
Headers show
Series [v2] libtirpc: Support ipv6 in DISTRO_FEATURES | expand

Commit Message

Jörg Sommer Oct. 12, 2023, 2:55 p.m. UTC
If the ipv6 feature for the distribution is not set, the package should not
contain settings for ipv6. This makes rpcbind doesn't try to bind to a IPv6
socket, and complain that this fails.

Signed-off-by: Jörg Sommer <joerg.sommer@navimatix.de>
---
 .../libtirpc/libtirpc/ipv6.patch              | 52 +++++++++++++++++++
 .../libtirpc/libtirpc_1.3.2.bb                |  6 +++
 2 files changed, 58 insertions(+)
 create mode 100644 meta/recipes-extended/libtirpc/libtirpc/ipv6.patch

Comments

Alexander Kanavin Oct. 12, 2023, 3:15 p.m. UTC | #1
Thanks!

Alex

On Thu 12. Oct 2023 at 16.56, Jörg Sommer via lists.openembedded.org
<joerg.sommer=navimatix.de@lists.openembedded.org> wrote:

> If the ipv6 feature for the distribution is not set, the package should not
> contain settings for ipv6. This makes rpcbind doesn't try to bind to a IPv6
> socket, and complain that this fails.
>
> Signed-off-by: Jörg Sommer <joerg.sommer@navimatix.de>
> ---
>  .../libtirpc/libtirpc/ipv6.patch              | 52 +++++++++++++++++++
>  .../libtirpc/libtirpc_1.3.2.bb                |  6 +++
>  2 files changed, 58 insertions(+)
>  create mode 100644 meta/recipes-extended/libtirpc/libtirpc/ipv6.patch
>
> diff --git a/meta/recipes-extended/libtirpc/libtirpc/ipv6.patch
> b/meta/recipes-extended/libtirpc/libtirpc/ipv6.patch
> new file mode 100644
> index 0000000000..f746f986f4
> --- /dev/null
> +++ b/meta/recipes-extended/libtirpc/libtirpc/ipv6.patch
> @@ -0,0 +1,52 @@
> +From 077bbd32e8b7474dc5f153997732e1e6aec7fad6 Mon Sep 17 00:00:00 2001
> +Message-Id: <
> 077bbd32e8b7474dc5f153997732e1e6aec7fad6.1697120796.git.joerg.sommer@navimatix.de
> >
> +From: =?UTF-8?q?J=C3=B6rg=20Sommer?= <joerg.sommer@navimatix.de>
> +Date: Thu, 12 Oct 2023 16:22:59 +0200
> +Subject: [PATCH] netconfig: remove tcp6, udp6 on --disable-ipv6
> +MIME-Version: 1.0
> +Content-Type: text/plain; charset=UTF-8
> +Content-Transfer-Encoding: 8bit
> +
> +If the configuration for IPv6 is disabled, the netconfig should not
> contain
> +settings for tcp6 and udp6.
> +
> +The test for the configure option didn't work, because it check the wrong
> +variable.
> +
> +Signed-off-by: Jörg Sommer <joerg.sommer@navimatix.de>
> +Upstream-Status: Submitted [libtirpc-devel@lists.sourceforge.net]
> +Upstream-Status: Submitted [linux-nfs@vger.kernel.org]
> +---
> + configure.ac    | 2 +-
> + doc/Makefile.am | 5 +++++
> + 2 files changed, 6 insertions(+), 1 deletion(-)
> +
> +diff --git a/configure.ac b/configure.ac
> +index fe6c517..b687f8d 100644
> +--- a/configure.ac
> ++++ b/configure.ac
> +@@ -64,7 +64,7 @@ fi
> + AC_ARG_ENABLE(ipv6,
> +       [AC_HELP_STRING([--disable-ipv6], [Disable IPv6 support
> @<:@default=no@:>@])],
> +       [],[enable_ipv6=yes])
> +-AM_CONDITIONAL(INET6, test "x$disable_ipv6" != xno)
> ++AM_CONDITIONAL(INET6, test "x$enable_ipv6" != xno)
> + if test "x$enable_ipv6" != xno; then
> +       AC_DEFINE(INET6, 1, [Define to 1 if IPv6 is available])
> + fi
> +diff --git a/doc/Makefile.am b/doc/Makefile.am
> +index d42ab90..b9678f6 100644
> +--- a/doc/Makefile.am
> ++++ b/doc/Makefile.am
> +@@ -2,3 +2,8 @@ dist_sysconf_DATA      = netconfig bindresvport.blacklist
> +
> + CLEANFILES           = cscope.* *~
> + DISTCLEANFILES               = Makefile.in
> ++
> ++if ! INET6
> ++install-exec-hook:
> ++      $(SED) -i '/^tcp6\|^udp6/d' "$(DESTDIR)$(sysconfdir)"/netconfig
> ++endif
> +--
> +2.34.1
> +
> diff --git a/meta/recipes-extended/libtirpc/libtirpc_1.3.2.bb
> b/meta/recipes-extended/libtirpc/libtirpc_1.3.2.bb
> index 6980135a92..dca5a964a8 100644
> --- a/meta/recipes-extended/libtirpc/libtirpc_1.3.2.bb
> +++ b/meta/recipes-extended/libtirpc/libtirpc_1.3.2.bb
> @@ -11,6 +11,7 @@ PROVIDES = "virtual/librpc"
>
>  SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${BP}.tar.bz2 \
>            file://CVE-2021-46828.patch \
> +          file://ipv6.patch \
>           "
>  UPSTREAM_CHECK_URI = "
> https://sourceforge.net/projects/libtirpc/files/libtirpc/"
>  UPSTREAM_CHECK_REGEX = "(?P<pver>\d+(\.\d+)+)/"
> @@ -20,6 +21,11 @@ inherit autotools pkgconfig
>
>  EXTRA_OECONF = "--disable-gssapi"
>
> +PACKAGECONFIG ??= " \
> +    ${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)} \
> +"
> +PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6"
> +
>  do_install:append() {
>         test -e ${D}${sysconfdir}/netconfig && chown root:root
> ${D}${sysconfdir}/netconfig
>  }
> --
> 2.34.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#189004):
> https://lists.openembedded.org/g/openembedded-core/message/189004
> Mute This Topic: https://lists.openembedded.org/mt/101919607/1686489
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [
> alex.kanavin@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
>
diff mbox series

Patch

diff --git a/meta/recipes-extended/libtirpc/libtirpc/ipv6.patch b/meta/recipes-extended/libtirpc/libtirpc/ipv6.patch
new file mode 100644
index 0000000000..f746f986f4
--- /dev/null
+++ b/meta/recipes-extended/libtirpc/libtirpc/ipv6.patch
@@ -0,0 +1,52 @@ 
+From 077bbd32e8b7474dc5f153997732e1e6aec7fad6 Mon Sep 17 00:00:00 2001
+Message-Id: <077bbd32e8b7474dc5f153997732e1e6aec7fad6.1697120796.git.joerg.sommer@navimatix.de>
+From: =?UTF-8?q?J=C3=B6rg=20Sommer?= <joerg.sommer@navimatix.de>
+Date: Thu, 12 Oct 2023 16:22:59 +0200
+Subject: [PATCH] netconfig: remove tcp6, udp6 on --disable-ipv6
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+If the configuration for IPv6 is disabled, the netconfig should not contain
+settings for tcp6 and udp6.
+
+The test for the configure option didn't work, because it check the wrong
+variable.
+
+Signed-off-by: Jörg Sommer <joerg.sommer@navimatix.de>
+Upstream-Status: Submitted [libtirpc-devel@lists.sourceforge.net]
+Upstream-Status: Submitted [linux-nfs@vger.kernel.org]
+---
+ configure.ac    | 2 +-
+ doc/Makefile.am | 5 +++++
+ 2 files changed, 6 insertions(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index fe6c517..b687f8d 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -64,7 +64,7 @@ fi
+ AC_ARG_ENABLE(ipv6,
+ 	[AC_HELP_STRING([--disable-ipv6], [Disable IPv6 support @<:@default=no@:>@])],
+ 	[],[enable_ipv6=yes])
+-AM_CONDITIONAL(INET6, test "x$disable_ipv6" != xno)
++AM_CONDITIONAL(INET6, test "x$enable_ipv6" != xno)
+ if test "x$enable_ipv6" != xno; then
+ 	AC_DEFINE(INET6, 1, [Define to 1 if IPv6 is available])
+ fi
+diff --git a/doc/Makefile.am b/doc/Makefile.am
+index d42ab90..b9678f6 100644
+--- a/doc/Makefile.am
++++ b/doc/Makefile.am
+@@ -2,3 +2,8 @@ dist_sysconf_DATA	= netconfig bindresvport.blacklist
+ 
+ CLEANFILES	       = cscope.* *~
+ DISTCLEANFILES	       = Makefile.in
++
++if ! INET6
++install-exec-hook:
++	$(SED) -i '/^tcp6\|^udp6/d' "$(DESTDIR)$(sysconfdir)"/netconfig
++endif
+-- 
+2.34.1
+
diff --git a/meta/recipes-extended/libtirpc/libtirpc_1.3.2.bb b/meta/recipes-extended/libtirpc/libtirpc_1.3.2.bb
index 6980135a92..dca5a964a8 100644
--- a/meta/recipes-extended/libtirpc/libtirpc_1.3.2.bb
+++ b/meta/recipes-extended/libtirpc/libtirpc_1.3.2.bb
@@ -11,6 +11,7 @@  PROVIDES = "virtual/librpc"
 
 SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${BP}.tar.bz2 \
 	   file://CVE-2021-46828.patch \
+	   file://ipv6.patch \
 	  "
 UPSTREAM_CHECK_URI = "https://sourceforge.net/projects/libtirpc/files/libtirpc/"
 UPSTREAM_CHECK_REGEX = "(?P<pver>\d+(\.\d+)+)/"
@@ -20,6 +21,11 @@  inherit autotools pkgconfig
 
 EXTRA_OECONF = "--disable-gssapi"
 
+PACKAGECONFIG ??= " \
+    ${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)} \
+"
+PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6"
+
 do_install:append() {
 	test -e ${D}${sysconfdir}/netconfig && chown root:root ${D}${sysconfdir}/netconfig
 }