diff mbox series

[3/3] zvariant: add ptest feature for zvariant test suite

Message ID 4f1ee72f98af8396292171efcf08d3db1efa44e8.1682178812.git.frederic.martinsons@gmail.com
State Accepted, archived
Commit 912bbec9fe44f22ab70c3553af6cb699543b8411
Headers show
Series [1/3] ptest-cargo.bbclass: create class | expand

Commit Message

Frédéric Martinsons April 22, 2023, 3:59 p.m. UTC
From: Frederic Martinsons <frederic.martinsons@gmail.com>

Signed-off-by: Frederic Martinsons <frederic.martinsons@gmail.com>
---
 .../recipes-extended/zvariant/zvariant_3.12.0.bb      | 11 ++++++++++-
 1 file changed, 10 insertions(+), 1 deletion(-)

Comments

Alexander Kanavin April 24, 2023, 7:47 a.m. UTC | #1
On Sat, 22 Apr 2023 at 18:00, Frederic Martinsons
<frederic.martinsons@gmail.com> wrote:

> +# zvariant is an indermediate product for the zbus project
> +# and so, it provided only a static lib (rlib) which fall only
> +# in -dev package
> +ALLOW_EMPTY:${PN} = "1"
> +RDEPENDS:${PN}-ptest:remove = "${PN}"

Only the first should be enough, why also the second? We generally try
to avoid :remove, as issues can be usually solved in better ways.

Alex
Frédéric Martinsons April 24, 2023, 8:26 a.m. UTC | #2
On Mon, 24 Apr 2023 at 09:47, Alexander Kanavin <alex.kanavin@gmail.com>
wrote:

> On Sat, 22 Apr 2023 at 18:00, Frederic Martinsons
> <frederic.martinsons@gmail.com> wrote:
>
> > +# zvariant is an indermediate product for the zbus project
> > +# and so, it provided only a static lib (rlib) which fall only
> > +# in -dev package
> > +ALLOW_EMPTY:${PN} = "1"
> > +RDEPENDS:${PN}-ptest:remove = "${PN}"
>
> Only the first should be enough, why also the second? We generally try
> to avoid :remove, as issues can be usually solved in better ways.
>
> Alex
>

Ok will remove it in a V2. It seems that I had a wrong state if I must had
add this line, but I did
a "bitbake -c cleanall zvariant && bitbake core-image-sato" and I didn't
have any rootfs
issue.
diff mbox series

Patch

diff --git a/meta-selftest/recipes-extended/zvariant/zvariant_3.12.0.bb b/meta-selftest/recipes-extended/zvariant/zvariant_3.12.0.bb
index 4285d11b72..6c69c80940 100644
--- a/meta-selftest/recipes-extended/zvariant/zvariant_3.12.0.bb
+++ b/meta-selftest/recipes-extended/zvariant/zvariant_3.12.0.bb
@@ -7,6 +7,8 @@  HOMEPAGE = "https://gitlab.freedesktop.org/dbus/zbus/"
 LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=b377b220f43d747efdec40d69fcaa69d"
 
+DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'ptest', 'glib-2.0', '', d)}"
+
 SRC_URI = " \
     git://gitlab.freedesktop.org/dbus/zbus;protocol=https;branch=main;subpath=zvariant \
     file://0001-Tweak-zvariant-crate-config.patch;striplevel=2 \
@@ -21,10 +23,17 @@  python do_clean_lic_file_symlink() {
 
 addtask clean_lic_file_symlink after do_unpack before do_patch
 
-inherit cargo cargo-update-recipe-crates
+inherit ptest-cargo pkgconfig cargo-update-recipe-crates
 
 # Remove this when the recipe is reproducible
 EXCLUDE_FROM_WORLD = "1"
 
 require ${BPN}-crates.inc
 require ${BPN}-git-crates.inc
+
+# zvariant is an indermediate product for the zbus project
+# and so, it provided only a static lib (rlib) which fall only
+# in -dev package
+ALLOW_EMPTY:${PN} = "1"
+RDEPENDS:${PN}-ptest:remove = "${PN}"
+