diff mbox series

[07/10] python3-sphinx: upgrade 5.1.1 -> 5.2.3

Message ID 4a11065d07d31ecc431564bbbc0371d956c37aae.1665270768.git.tim.orling@konsulko.com
State Accepted, archived
Commit 951589b96e8545b13d9c5f8aeb61f85681720088
Headers show
Series [01/10] python3-cryptography: upgrade 37.0.4 -> 38.0.1 | expand

Commit Message

Tim Orling Oct. 8, 2022, 11:54 p.m. UTC
* Now uses flit-core backend (python_flit_core.bbclass)
* Sort RDEPENDS alphabetically to make it easier to see what is present.

For changes see:
https://www.sphinx-doc.org/en/master/changes.html#release-5-2-3-released-sep-30-2022
https://www.sphinx-doc.org/en/master/changes.html#release-5-2-2-released-sep-27-2022
https://www.sphinx-doc.org/en/master/changes.html#release-5-2-0-post0-released-sep-24-2022
https://www.sphinx-doc.org/en/master/changes.html#release-5-2-0-released-sep-24-2022

Signed-off-by: Tim Orling <tim.orling@konsulko.com>
---
 ...phinx_5.1.1.bb => python3-sphinx_5.2.3.bb} | 25 +++++++++++++------
 1 file changed, 17 insertions(+), 8 deletions(-)
 rename meta/recipes-devtools/python/{python3-sphinx_5.1.1.bb => python3-sphinx_5.2.3.bb} (48%)
diff mbox series

Patch

diff --git a/meta/recipes-devtools/python/python3-sphinx_5.1.1.bb b/meta/recipes-devtools/python/python3-sphinx_5.2.3.bb
similarity index 48%
rename from meta/recipes-devtools/python/python3-sphinx_5.1.1.bb
rename to meta/recipes-devtools/python/python3-sphinx_5.2.3.bb
index 1bef20c2e25..957bd17fc07 100644
--- a/meta/recipes-devtools/python/python3-sphinx_5.1.1.bb
+++ b/meta/recipes-devtools/python/python3-sphinx_5.2.3.bb
@@ -6,9 +6,9 @@  LIC_FILES_CHKSUM = "file://LICENSE;md5=72c536e78c21c567311b193fe00cd253"
 
 PYPI_PACKAGE = "Sphinx"
 
-SRC_URI[sha256sum] = "ba3224a4e206e1fbdecf98a4fae4992ef9b24b85ebf7b584bb340156eaf08d89"
+SRC_URI[sha256sum] = "5b10cb1022dac8c035f75767799c39217a05fc0fe2d6fe5597560d38e44f0363"
 
-inherit setuptools3 pypi
+inherit python_flit_core pypi
 
  
 do_install:append () {
@@ -17,12 +17,21 @@  do_install:append () {
 }
 
 RDEPENDS:${PN} = "\
-    python3-packaging python3-docutils python3-requests \
-    python3-imagesize python3-alabaster python3-jinja2 \
-    python3-babel python3-pygments python3-snowballstemmer \
-    python3-sphinxcontrib-applehelp python3-sphinxcontrib-devhelp \
-    python3-sphinxcontrib-jsmath python3-sphinxcontrib-htmlhelp \
-    python3-sphinxcontrib-serializinghtml python3-sphinxcontrib-qthelp \
+    python3-alabaster \
+    python3-babel \
+    python3-docutils \
+    python3-imagesize \
+    python3-jinja2 \
+    python3-packaging \
+    python3-pygments \
+    python3-requests \
+    python3-snowballstemmer \
+    python3-sphinxcontrib-applehelp \
+    python3-sphinxcontrib-devhelp \
+    python3-sphinxcontrib-htmlhelp \
+    python3-sphinxcontrib-jsmath \
+    python3-sphinxcontrib-qthelp \
+    python3-sphinxcontrib-serializinghtml \
     "
 
 BBCLASSEXTEND = "native nativesdk"