diff mbox series

[15/15] linux-yocto-tiny/6.4: fix configuration warnings (HID)

Message ID 3837299eb34f742d064e4aca39a63712e9cfa953.1688958789.git.bruce.ashfield@gmail.com
State Accepted, archived
Commit 32e2396402ab954da3df89eab1a900043661d20f
Headers show
Series [01/15] linux-yocto/6.1: update to v6.1.36 | expand

Commit Message

Bruce Ashfield July 10, 2023, 3:20 a.m. UTC
From: Bruce Ashfield <bruce.ashfield@gmail.com>

When building -tiny for qemux86 on 6.4, CONFIG_HID related warnings
were observed.

 [NOTE]: 'CONFIG_HID_WACOM' last val (y) and .config val (n) do not match
 [NOTE]: 'CONFIG_USB_HID' last val (y) and .config val (n) do not match
 [NOTE]: 'CONFIG_USB_HIDDEV' last val (y) and .config val (n) do not match

This is due to our allnoconfig baseline disabling HID, which dependent
drivers require.

Rather than universally enabling CONFIG_HID in the base tiny ktype, we
can create a fragment and include it from the common-pc tiny kernel
entry point.

    252c55e236c common-pc/tiny: enable HID by default
    849f920aa1b cfg: add CONFIG_HID base fragment

Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
---
 meta/recipes-kernel/linux/linux-yocto-rt_6.4.bb   | 2 +-
 meta/recipes-kernel/linux/linux-yocto-tiny_6.4.bb | 2 +-
 meta/recipes-kernel/linux/linux-yocto_6.4.bb      | 2 +-
 3 files changed, 3 insertions(+), 3 deletions(-)
diff mbox series

Patch

diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_6.4.bb b/meta/recipes-kernel/linux/linux-yocto-rt_6.4.bb
index bd340adc15..a860232bf0 100644
--- a/meta/recipes-kernel/linux/linux-yocto-rt_6.4.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_6.4.bb
@@ -15,7 +15,7 @@  python () {
 }
 
 SRCREV_machine ?= "0c7d2016a3a548fd8f7caf7b1f46abd71008cd5c"
-SRCREV_meta ?= "8a09ea80e6905baf80940dc8c4fe9326bd8d19e2"
+SRCREV_meta ?= "4655de57a68a86e651fcea2eb2c7e88f3de3bbfb"
 
 SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;branch=${KBRANCH};name=machine;protocol=https \
            git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-6.4;destsuffix=${KMETA};protocol=https"
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_6.4.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_6.4.bb
index 6490c69b93..d4b36d0e50 100644
--- a/meta/recipes-kernel/linux/linux-yocto-tiny_6.4.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_6.4.bb
@@ -18,7 +18,7 @@  KMETA = "kernel-meta"
 KCONF_BSP_AUDIT_LEVEL = "2"
 
 SRCREV_machine ?= "2bf4f46721ce8095f156566128a9feee2da09d20"
-SRCREV_meta ?= "8a09ea80e6905baf80940dc8c4fe9326bd8d19e2"
+SRCREV_meta ?= "4655de57a68a86e651fcea2eb2c7e88f3de3bbfb"
 
 PV = "${LINUX_VERSION}+git${SRCPV}"
 
diff --git a/meta/recipes-kernel/linux/linux-yocto_6.4.bb b/meta/recipes-kernel/linux/linux-yocto_6.4.bb
index e514251673..9ae3fc4221 100644
--- a/meta/recipes-kernel/linux/linux-yocto_6.4.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_6.4.bb
@@ -28,7 +28,7 @@  SRCREV_machine:qemux86 ?= "2bf4f46721ce8095f156566128a9feee2da09d20"
 SRCREV_machine:qemux86-64 ?= "2bf4f46721ce8095f156566128a9feee2da09d20"
 SRCREV_machine:qemumips64 ?= "4dddf5763b3a26b7892ed75d02bcb9c25a3fe703"
 SRCREV_machine ?= "2bf4f46721ce8095f156566128a9feee2da09d20"
-SRCREV_meta ?= "8a09ea80e6905baf80940dc8c4fe9326bd8d19e2"
+SRCREV_meta ?= "4655de57a68a86e651fcea2eb2c7e88f3de3bbfb"
 
 # set your preferred provider of linux-yocto to 'linux-yocto-upstream', and you'll
 # get the <version>/base branch, which is pure upstream -stable, and the same