diff mbox series

[langdale,19/30] lsof: add update-alternatives logic

Message ID 3217ea61a1721df1b26f6e0695f03a50f21ebac8.1671122751.git.steve@sakoman.com
State New
Headers show
Series [langdale,01/30] libarchive: CVE-2022-36227 NULL pointer dereference in archive_write.c | expand

Commit Message

Steve Sakoman Dec. 15, 2022, 7:20 p.m. UTC
From: Alex Stewart <alex.stewart@ni.com>

Some distributions (NI LinuxRT) provide both busybox-lsof and
full-featured lsof implementations. When users install the full-featured
lsof package, the full-binary fails to replace the bbox-binary in PATH,
because `lsof` contains no update-alternatives logic.

Inherit the update-alternatives bbclass and assert that the
full-featured lsof package has higher priority than the busybox
implementation.

Co-Authored-By: Kyle Roeschley <kyle.roeschley@ni.com>
Signed-off-by: Alex Stewart <alex.stewart@ni.com>
Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com>
(cherry picked from commit e2893fa692a6e91eee09fc04c8c03fe27c718a58)
Signed-off-by: Steve Sakoman <steve@sakoman.com>
---
 meta/recipes-extended/lsof/lsof_4.95.0.bb | 9 +++++++++
 1 file changed, 9 insertions(+)
diff mbox series

Patch

diff --git a/meta/recipes-extended/lsof/lsof_4.95.0.bb b/meta/recipes-extended/lsof/lsof_4.95.0.bb
index f380de0b6b..80128369ec 100644
--- a/meta/recipes-extended/lsof/lsof_4.95.0.bb
+++ b/meta/recipes-extended/lsof/lsof_4.95.0.bb
@@ -19,6 +19,15 @@  SRCREV = "67d8c828e7bdc01ba93f8ff79765dd424da0c9d7"
 
 S = "${WORKDIR}/git"
 
+
+inherit update-alternatives
+
+ALTERNATIVE_${PN} = "lsof"
+ALTERNATIVE_LINK_NAME[lsof] = "${sbindir}/lsof"
+# Make our priority higher than busybox
+ALTERNATIVE_PRIORITY = "100"
+
+
 export LSOF_INCLUDE = "${STAGING_INCDIR}"
 
 do_configure () {