diff mbox series

[1/2] llvm: Upgrade to 18.1.3 bugfix release

Message ID 20240406171047.1527823-1-raj.khem@gmail.com
State Accepted, archived
Commit f6a561db603a6583969137fdd9fb4ec0138bff46
Headers show
Series [1/2] llvm: Upgrade to 18.1.3 bugfix release | expand

Commit Message

Khem Raj April 6, 2024, 5:10 p.m. UTC
Brings following changes
* c13b7485b879 [clang] Avoid -Wshadow warning when init-capture named same as class field (#74512)
* f249092ef26d [tsan] Refine fstat{,64} interceptors (#86625)
* 76c721994a11 [clang][Sema] Fix a CTAD regression after 42239d2e9 (#86914)
* e0f0c463b539 [mlir][transform] replace original op to loop ops (#83537)
* 47aac495c895 [OpenMP][AIX] Affinity implementation for AIX (#84984)
* a385a917da93 [Support] Fix color handling in formatted_raw_ostream (#86700)
* 0cd4babe0342 Reapply [libcxx] [modules] Fix relative paths with absolute LIBCXX_INSTALL_MODULES_DIR (#86020)
* cfaeee6a8994  release/18.x: [SystemZ] Fix overflow flag for i128 USUBO (#86491)
* 767b61c159b3 [lld/ELF][X86] Respect outSecOff when checking if GOTPCREL can be relaxed (#86334)
* 7c7c3d4a3a27 [ODS][NFC] Cast range.size() to int32_t in accumulation (#85629)
* 0e501dbd932e [Mips] Restore wrong deletion of instruction 'and' in unsigned min/max processing. (#85902)
* fbb27d16fa12 [Mips] Fix missing sign extension in expansion of sub-word atomic max (#77072)
* e74c1678231a [PowerPC] provide CFI for ELF32 to unwind cr2, cr3, cr4 (#83098)
* 1c7c16e58240 [NFC][PowerPC] use script to regenerate the CHECK lines
* c2a57034eff0 [msan] Re-exec with no ASLR if memory layout is incompatible on Linux (#85142)
* b74f6158460c [msan] Add 'MappingDesc::ALLOCATOR' type and check it is available (#85153)
* 98a15dd2d728 [clang][CodeGen] Allow `memcpy` replace with trivial auto var init
* 2498e3a07f3d [LoongArch] Assume no-op addrspacecasts by default (#82332)
* 368dc8553c5a [SROA]: Only defer trying partial sized ptr or ptr vector types
* 0e16af8e4cf3 [ARM] Update IsRestored for LR based on all returns (#82745)
* 6f8016fda7d5 Pre-commit test showing bug #80287
* ef6d1ec07c69 Bump version to 18.1.3 (#86168)

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 meta/recipes-devtools/llvm/llvm_git.bb | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/meta/recipes-devtools/llvm/llvm_git.bb b/meta/recipes-devtools/llvm/llvm_git.bb
index e1d5fc47a1f..c4fd73f2d7a 100644
--- a/meta/recipes-devtools/llvm/llvm_git.bb
+++ b/meta/recipes-devtools/llvm/llvm_git.bb
@@ -17,14 +17,14 @@  inherit cmake pkgconfig
 # could be 'rcX' or 'git' or empty ( for release )
 VER_SUFFIX = ""
 
-PV = "18.1.2${VER_SUFFIX}"
+PV = "18.1.3${VER_SUFFIX}"
 
 MAJOR_VERSION = "${@oe.utils.trim_version("${PV}", 1)}"
 
 LLVM_RELEASE = "${PV}"
 
 BRANCH = "release/${MAJOR_VERSION}.x"
-SRCREV = "26a1d6601d727a96f4301d0d8647b5a42760ae0c"
+SRCREV = "c13b7485b87909fcf739f62cfa382b55407433c0"
 SRC_URI = "git://github.com/llvm/llvm-project.git;branch=${BRANCH};protocol=https \
            file://0007-llvm-allow-env-override-of-exe-path.patch;striplevel=2 \
            file://0001-AsmMatcherEmitter-sort-ClassInfo-lists-by-name-as-we.patch;striplevel=2 \