diff mbox series

[RFC,v2] perf: make bpf asm include arch conditional

Message ID 20240405131516.4056515-1-bruce.ashfield@gmail.com
State Accepted, archived
Commit 879b4a7d378b4d4d11fdda7921b8c47e4523a948
Headers show
Series [RFC,v2] perf: make bpf asm include arch conditional | expand

Commit Message

Bruce Ashfield April 5, 2024, 1:15 p.m. UTC
From: Bruce Ashfield <bruce.ashfield@gmail.com>

To keep the perf source copying as small as possible, we can
further refine the arch/uapi copy to the single file that we
currently need.

To avoid a warning from the general perf source copy routine,
we make the .h conditional based on the architecture.

The supported architectures will not change often, so updating
this arch list is very minimal effort. Alternatively, we could
add a PERF_OPTIONAL_SRC variable and not warn if a file isn't
available for a given architecture.

Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
---

v2: As suggested by Max Krummenacher <max.oss.09@gmail.com>
powerpc doesn't need to be listed in the architectures that
require this file. I've also clarified the comment in the
recipe to indicate we are only listing supported archs at
the moment.

Bruce

 meta/recipes-kernel/perf/perf.bb | 7 +++++--
 1 file changed, 5 insertions(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/meta/recipes-kernel/perf/perf.bb b/meta/recipes-kernel/perf/perf.bb
index 2f540cd54b..095ec0f281 100644
--- a/meta/recipes-kernel/perf/perf.bb
+++ b/meta/recipes-kernel/perf/perf.bb
@@ -129,7 +129,10 @@  EXTRA_OEMAKE += "\
 # honour a JOBS variable.
 EXTRA_OEMAKE:append:task-configure = " JOBS=1"
 
-# include/uapi/asm is for: include/uapi/asm/bpf_perf_event.h
+# the architectures that need this file can be found in
+#    tools/include/uapi/asm/bpf_perf_event.h
+# We are only listing supported arches at the moment
+PERF_BPF_EVENT_SRC ?= '${@bb.utils.contains_any("ARCH", [ "riscv", "arm64" ], "arch/${ARCH}/include/uapi/asm/bpf_perf_event.h", "", d)}'
 PERF_SRC ?= "Makefile \
              tools/arch \
              tools/build \
@@ -140,7 +143,7 @@  PERF_SRC ?= "Makefile \
              tools/scripts \
              scripts/ \
              arch/arm64/tools \
-             arch/${ARCH}/include/uapi/asm/ \
+             ${PERF_BPF_EVENT_SRC} \
              arch/${ARCH}/Makefile \
 "