diff mbox series

[1/2] acpica: use github for SRC_URI

Message ID 20240403152727.2247873-2-jdmason@kudzu.us
State Accepted, archived
Commit 7122db6d368170a6a428f3028a221e4036114d68
Headers show
Series acpica: switch to github and update version | expand

Commit Message

Jon Mason April 3, 2024, 3:27 p.m. UTC
Github is now the location of the ACPICA source code, per
https://www.intel.com/content/www/us/en/developer/topic-technology/open/acpica/download.html
Update to this location.  Also, this allows for devtool check for new
versions (in theory), and allows for an easier collection of the
changelog when updating versions.

Using the SRCREV SHA that matches the tarball release.  So, this should
match what is currently being used.

Signed-off-by: Jon Mason <jdmason@kudzu.us>
---
 meta/recipes-extended/acpica/acpica_20230628.bb | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)

Comments

Alexander Kanavin April 3, 2024, 4:01 p.m. UTC | #1
On Wed, 3 Apr 2024 at 17:27, Jon Mason <jdmason@kudzu.us> wrote:
> -UPSTREAM_CHECK_URI = "https://www.intel.com/content/www/us/en/download/776303/acpi-component-architecture-downloads-unix-format-source-code-and-build-environment-with-an-intel-license.html"
> -UPSTREAM_VERSION_UNKNOWN = "1"
> +UPSTREAM_CHECK_URI = "https://github.com/${BPN}/${BPN}/releases/"
> +UPSTREAM_CHECK_REGEX = "releases/tag/G?(?P<pver>\d+(\.\d+)+)"

It is not necessary to add these lines. By default git upstream check
will get all the tags with git itself, then sort them and pick what
came on top, subject to UPSTREAM_CHECK_GITTAGREGEX if that is set.

Alex
Jon Mason April 3, 2024, 4:56 p.m. UTC | #2
Fixed! v2 coming

On Wed, Apr 3, 2024 at 12:01 PM Alexander Kanavin
<alex.kanavin@gmail.com> wrote:
>
> On Wed, 3 Apr 2024 at 17:27, Jon Mason <jdmason@kudzu.us> wrote:
> > -UPSTREAM_CHECK_URI = "https://www.intel.com/content/www/us/en/download/776303/acpi-component-architecture-downloads-unix-format-source-code-and-build-environment-with-an-intel-license.html"
> > -UPSTREAM_VERSION_UNKNOWN = "1"
> > +UPSTREAM_CHECK_URI = "https://github.com/${BPN}/${BPN}/releases/"
> > +UPSTREAM_CHECK_REGEX = "releases/tag/G?(?P<pver>\d+(\.\d+)+)"
>
> It is not necessary to add these lines. By default git upstream check
> will get all the tags with git itself, then sort them and pick what
> came on top, subject to UPSTREAM_CHECK_GITTAGREGEX if that is set.
>
> Alex
diff mbox series

Patch

diff --git a/meta/recipes-extended/acpica/acpica_20230628.bb b/meta/recipes-extended/acpica/acpica_20230628.bb
index 8974bdc1f1a6..e63faebf0901 100644
--- a/meta/recipes-extended/acpica/acpica_20230628.bb
+++ b/meta/recipes-extended/acpica/acpica_20230628.bb
@@ -16,13 +16,13 @@  COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux"
 
 DEPENDS = "m4-native flex-native bison-native"
 
-SRC_URI = "https://downloadmirror.intel.com/783534/acpica-unix-${PV}.tar.gz"
-SRC_URI[sha256sum] = "86876a745e3d224dcfd222ed3de465b47559e85811df2db9820ef09a9dff5cce"
+SRC_URI = "git://github.com/acpica/acpica;protocol=https;branch=master"
+SRCREV = "f16a0b4d0f0edd7b78a332fcf507be2187fac21e"
 
-UPSTREAM_CHECK_URI = "https://www.intel.com/content/www/us/en/download/776303/acpi-component-architecture-downloads-unix-format-source-code-and-build-environment-with-an-intel-license.html"
-UPSTREAM_VERSION_UNKNOWN = "1"
+UPSTREAM_CHECK_URI = "https://github.com/${BPN}/${BPN}/releases/"
+UPSTREAM_CHECK_REGEX = "releases/tag/G?(?P<pver>\d+(\.\d+)+)"
 
-S = "${WORKDIR}/acpica-unix-${PV}"
+S = "${WORKDIR}/git"
 
 inherit update-alternatives