diff mbox series

python3-gpiod: add recipe

Message ID 20240318093554.2521527-1-xiangyu.chen@eng.windriver.com
State New
Headers show
Series python3-gpiod: add recipe | expand

Commit Message

Xiangyu Chen March 18, 2024, 9:35 a.m. UTC
From: Xiangyu Chen <xiangyu.chen@windriver.com>

python3-gpiod is a python library for interacting with the linux GPIO
character device, it provides a simple way to control a GPIO in less code.

Signed-off-by: Xiangyu Chen <xiangyu.chen@windriver.com>
---
 meta/recipes-devtools/python/python3-gpiod_1.5.4.bb | 12 ++++++++++++
 1 file changed, 12 insertions(+)
 create mode 100644 meta/recipes-devtools/python/python3-gpiod_1.5.4.bb

Comments

Quentin Schulz March 18, 2024, 9:34 a.m. UTC | #1
Hi Xiangyu Chen,

On 3/18/24 10:35, Xiangyu Chen via lists.openembedded.org wrote:
> From: Xiangyu Chen <xiangyu.chen@windriver.com>
> 
> python3-gpiod is a python library for interacting with the linux GPIO
> character device, it provides a simple way to control a GPIO in less code.
> 
> Signed-off-by: Xiangyu Chen <xiangyu.chen@windriver.com>
> ---
>   meta/recipes-devtools/python/python3-gpiod_1.5.4.bb | 12 ++++++++++++
>   1 file changed, 12 insertions(+)
>   create mode 100644 meta/recipes-devtools/python/python3-gpiod_1.5.4.bb
> 
> diff --git a/meta/recipes-devtools/python/python3-gpiod_1.5.4.bb b/meta/recipes-devtools/python/python3-gpiod_1.5.4.bb
> new file mode 100644
> index 0000000000..21f0f35cbb
> --- /dev/null
> +++ b/meta/recipes-devtools/python/python3-gpiod_1.5.4.bb
> @@ -0,0 +1,12 @@
> +SUMMARY = "Python library for interacting with GPIO"
> +DESCRIPTION = "Python library for interacting with the linux GPIO \
> +character device. It is a pure Python library and has no dependencies on \
> +other packages."
> +HOMEPAGE = "https://github.com/hhk7734/python3-gpiod"
> +BUGTRACKER = "https://github.com/hhk7734/python3-gpiod/issues"
> +LICENSE = "MIT"
> +LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=fc4e57275d8c245894e576844466f725"
> +
> +inherit pypi python_setuptools_build_meta
> +
> +SRC_URI[sha256sum] = "d8e4daa655dee75c33a49f5859b2e36c72385021c06c5552968294b1ad5c2dd0"
> 

I would highly recommend to use the newer version of gpiod.

 From the pypi package[1]

"""
Versions 1.5.4 and prior are the deprecated, unofficial, pure-Python 
bindings.
"""

To give a bit more feedback, the same gpiod PyPi package comes from two 
different git repos. Before (and including) v1.5.4, it comes from 
https://github.com/hhk7734/python3-gpiod. Any version after that comes 
from https://git.kernel.org/pub/scm/libs/libgpiod/libgpiod.git/.

The latter is maintained by one of the Linux kernel GPIO subsystem 
maintainer and the former has been abandoned as far as I remember.

c.f. https://github.com/hhk7734/python3-gpiod/issues/39 for more info on 
gpiod package in PyPi.

Cheers,
Quentin

[1] https://pypi.org/project/gpiod/
Khem Raj March 18, 2024, 4:48 p.m. UTC | #2
its already available in meta-python and has a more recent version
2.1.3, is there anything needing it in such a way that
we need to move it to the core layer ?

On Mon, Mar 18, 2024 at 1:56 AM Xiangyu Chen
<xiangyu.chen@eng.windriver.com> wrote:
>
> From: Xiangyu Chen <xiangyu.chen@windriver.com>
>
> python3-gpiod is a python library for interacting with the linux GPIO
> character device, it provides a simple way to control a GPIO in less code.
>
> Signed-off-by: Xiangyu Chen <xiangyu.chen@windriver.com>
> ---
>  meta/recipes-devtools/python/python3-gpiod_1.5.4.bb | 12 ++++++++++++
>  1 file changed, 12 insertions(+)
>  create mode 100644 meta/recipes-devtools/python/python3-gpiod_1.5.4.bb
>
> diff --git a/meta/recipes-devtools/python/python3-gpiod_1.5.4.bb b/meta/recipes-devtools/python/python3-gpiod_1.5.4.bb
> new file mode 100644
> index 0000000000..21f0f35cbb
> --- /dev/null
> +++ b/meta/recipes-devtools/python/python3-gpiod_1.5.4.bb
> @@ -0,0 +1,12 @@
> +SUMMARY = "Python library for interacting with GPIO"
> +DESCRIPTION = "Python library for interacting with the linux GPIO \
> +character device. It is a pure Python library and has no dependencies on \
> +other packages."
> +HOMEPAGE = "https://github.com/hhk7734/python3-gpiod"
> +BUGTRACKER = "https://github.com/hhk7734/python3-gpiod/issues"
> +LICENSE = "MIT"
> +LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=fc4e57275d8c245894e576844466f725"
> +
> +inherit pypi python_setuptools_build_meta
> +
> +SRC_URI[sha256sum] = "d8e4daa655dee75c33a49f5859b2e36c72385021c06c5552968294b1ad5c2dd0"
> --
> 2.25.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#197296): https://lists.openembedded.org/g/openembedded-core/message/197296
> Mute This Topic: https://lists.openembedded.org/mt/104999059/1997914
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
diff mbox series

Patch

diff --git a/meta/recipes-devtools/python/python3-gpiod_1.5.4.bb b/meta/recipes-devtools/python/python3-gpiod_1.5.4.bb
new file mode 100644
index 0000000000..21f0f35cbb
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-gpiod_1.5.4.bb
@@ -0,0 +1,12 @@ 
+SUMMARY = "Python library for interacting with GPIO"
+DESCRIPTION = "Python library for interacting with the linux GPIO \
+character device. It is a pure Python library and has no dependencies on \
+other packages."
+HOMEPAGE = "https://github.com/hhk7734/python3-gpiod"
+BUGTRACKER = "https://github.com/hhk7734/python3-gpiod/issues"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=fc4e57275d8c245894e576844466f725"
+
+inherit pypi python_setuptools_build_meta
+
+SRC_URI[sha256sum] = "d8e4daa655dee75c33a49f5859b2e36c72385021c06c5552968294b1ad5c2dd0"