diff mbox series

[10/21] libtraceevent: update 1.7.3 -> 1.8.2

Message ID 20240313173336.3900178-10-alex@linutronix.de
State New
Headers show
Series [01/21] meson: correct upstream version check (exclude pre-releases) | expand

Commit Message

Alexander Kanavin March 13, 2024, 5:33 p.m. UTC
Drop docs option from meson.patch, as upstream added a doc
option that does the same thing.

Signed-off-by: Alexander Kanavin <alex@linutronix.de>
---
 .../libtraceevent/libtraceevent/meson.patch   | 47 ++++---------------
 ...eevent_1.7.3.bb => libtraceevent_1.8.2.bb} |  4 +-
 2 files changed, 11 insertions(+), 40 deletions(-)
 rename meta/recipes-kernel/libtraceevent/{libtraceevent_1.7.3.bb => libtraceevent_1.8.2.bb} (89%)
diff mbox series

Patch

diff --git a/meta/recipes-kernel/libtraceevent/libtraceevent/meson.patch b/meta/recipes-kernel/libtraceevent/libtraceevent/meson.patch
index 38b6107136f..0c21b2347a1 100644
--- a/meta/recipes-kernel/libtraceevent/libtraceevent/meson.patch
+++ b/meta/recipes-kernel/libtraceevent/libtraceevent/meson.patch
@@ -1,14 +1,20 @@ 
-Fixes for the Meson build of libtraceevent:
+From 7f88c9ba5f27276e844252500a9f0ba2b350b919 Mon Sep 17 00:00:00 2001
+From: Ross Burton <ross.burton@arm.com>
+Date: Sun, 27 Aug 2023 20:57:44 +0100
+Subject: [PATCH] Fixes for the Meson build of libtraceevent:
 
 - Make the plugin directory the same as the Makefiles
 - Install the plugins as modules not static and versioned shared libraries
-- Add an option to disable building the documentation (needs asciidoc and xmlto)
 
 Upstream-Status: Pending
 Signed-off-by: Ross Burton <ross.burton@arm.com>
+---
+ meson.build         | 2 +-
+ plugins/meson.build | 3 +--
+ 2 files changed, 2 insertions(+), 3 deletions(-)
 
 diff --git a/meson.build b/meson.build
-index b61c873..4bba4d8 100644
+index 40ce38c..1eb7912 100644
 --- a/meson.build
 +++ b/meson.build
 @@ -25,7 +25,7 @@ htmldir = join_paths(prefixdir, get_option('htmldir'))
@@ -20,41 +26,6 @@  index b61c873..4bba4d8 100644
  endif
  
  add_project_arguments(
-@@ -45,10 +45,13 @@ if cunit_dep.found()
-     subdir('utest')
- endif
- subdir('samples')
--subdir('Documentation')
- 
--custom_target(
--    'docs',
--    output: 'docs',
--    depends: [html, man],
--    command: ['echo'])
-+if get_option('docs')
-+    subdir('Documentation')
-+
-+    custom_target(
-+        'docs',
-+        output: 'docs',
-+        depends: [html, man],
-+        command: ['echo'])
-+endif
-diff --git a/meson_options.txt b/meson_options.txt
-index b2294f6..0611216 100644
---- a/meson_options.txt
-+++ b/meson_options.txt
-@@ -4,6 +4,10 @@
- 
- option('plugindir', type : 'string',
-        description : 'set the plugin dir')
-+
-+option('docs', type : 'boolean', value: true,
-+       description : 'build documentation')
-+
- option('htmldir', type : 'string', value : 'share/doc/libtraceevent-doc',
-        description : 'directory for HTML documentation')
- option('asciidoctor', type : 'boolean', value: false,
 diff --git a/plugins/meson.build b/plugins/meson.build
 index 74ad664..4919be4 100644
 --- a/plugins/meson.build
diff --git a/meta/recipes-kernel/libtraceevent/libtraceevent_1.7.3.bb b/meta/recipes-kernel/libtraceevent/libtraceevent_1.8.2.bb
similarity index 89%
rename from meta/recipes-kernel/libtraceevent/libtraceevent_1.7.3.bb
rename to meta/recipes-kernel/libtraceevent/libtraceevent_1.8.2.bb
index bee7891832a..d4ace548840 100644
--- a/meta/recipes-kernel/libtraceevent/libtraceevent_1.7.3.bb
+++ b/meta/recipes-kernel/libtraceevent/libtraceevent_1.8.2.bb
@@ -8,7 +8,7 @@  LIC_FILES_CHKSUM = "file://LICENSES/GPL-2.0;md5=e6a75371ba4d16749254a51215d13f97
                     file://LICENSES/LGPL-2.1;md5=b370887980db5dd40659b50909238dbd"
 SECTION = "libs"
 
-SRCREV = "dd148189b74da3e2f45c7e536319fec97cb71213"
+SRCREV = "6f6d5802f31992e7527a4c32b43a32fda6bf6bdf"
 SRC_URI = "git://git.kernel.org/pub/scm/libs/libtrace/libtraceevent.git;branch=${BPN};protocol=https \
            file://meson.patch"
 
@@ -16,7 +16,7 @@  S = "${WORKDIR}/git"
 
 inherit meson pkgconfig
 
-EXTRA_OEMESON = "-Ddocs=false"
+EXTRA_OEMESON = "-Ddoc=false"
 
 PACKAGES += "${PN}-plugins"