diff mbox series

[v2] bmaptool: Add bmap-tools runtime alias for compatibility

Message ID 20240307134316.3047342-1-tom.hochstein@nxp.com
State Accepted, archived
Commit fba4ac04524c5c3fa04a51b6e0679276327115ad
Headers show
Series [v2] bmaptool: Add bmap-tools runtime alias for compatibility | expand

Commit Message

Tom Hochstein March 7, 2024, 1:43 p.m. UTC
The rename of bmap-tools to bmaptool creates an incompatibility that
will break package feeds. Restore compatibility by adding bmap-tools as
a runtime alias.

Acked-by: Otavio Salvador <otavio@ossystems.com.br>
Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
---
 meta/recipes-support/bmaptool/bmaptool_git.bb | 5 +++++
 1 file changed, 5 insertions(+)

Comments

Alexander Kanavin March 7, 2024, 4:13 p.m. UTC | #1
On Thu, 7 Mar 2024 at 14:43, Tom Hochstein <tom.hochstein@nxp.com> wrote:
> +# For compatibility with layers before scarthgap
> +RPROVIDES:${PN} = "bmap-tools"
> +RREPLACES:${PN} = "bmap-tools"
> +RCONFLICTS:${PN} = "bmap-tools"

Only RREPLACES/RCONFLICTS please. Do not add the obsolete RPROVIDES.

Alex
Otavio Salvador March 7, 2024, 4:17 p.m. UTC | #2
Em qui., 7 de mar. de 2024 às 13:14, Alexander Kanavin <
alex.kanavin@gmail.com> escreveu:

> On Thu, 7 Mar 2024 at 14:43, Tom Hochstein <tom.hochstein@nxp.com> wrote:
> > +# For compatibility with layers before scarthgap
> > +RPROVIDES:${PN} = "bmap-tools"
> > +RREPLACES:${PN} = "bmap-tools"
> > +RCONFLICTS:${PN} = "bmap-tools"
>
> Only RREPLACES/RCONFLICTS please. Do not add the obsolete RPROVIDES.
>

For package feed upgrade it is required.
Alexander Kanavin March 7, 2024, 4:40 p.m. UTC | #3
Is it? Why? There’s plenty of recipes in core  that don’t do it. Package
managers resolvers are able to figure out that one package needs to be
replaced with another.

Alex

On Thu 7. Mar 2024 at 17.17, Otavio Salvador <
otavio.salvador@ossystems.com.br> wrote:

>
>
> Em qui., 7 de mar. de 2024 às 13:14, Alexander Kanavin <
> alex.kanavin@gmail.com> escreveu:
>
>> On Thu, 7 Mar 2024 at 14:43, Tom Hochstein <tom.hochstein@nxp.com> wrote:
>> > +# For compatibility with layers before scarthgap
>> > +RPROVIDES:${PN} = "bmap-tools"
>> > +RREPLACES:${PN} = "bmap-tools"
>> > +RCONFLICTS:${PN} = "bmap-tools"
>>
>> Only RREPLACES/RCONFLICTS please. Do not add the obsolete RPROVIDES.
>>
>
> For package feed upgrade it is required.
>
> --
> Otavio Salvador                             O.S. Systems
> http://www.ossystems.com.br        http://code.ossystems.com.br
> Mobile: +55 (53) 9 9981-7854          Mobile: +1 (347) 903-9750
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#196805):
> https://lists.openembedded.org/g/openembedded-core/message/196805
> Mute This Topic: https://lists.openembedded.org/mt/104787184/1686489
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [
> alex.kanavin@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
>
diff mbox series

Patch

diff --git a/meta/recipes-support/bmaptool/bmaptool_git.bb b/meta/recipes-support/bmaptool/bmaptool_git.bb
index 87328af8c6..f0f3b85902 100644
--- a/meta/recipes-support/bmaptool/bmaptool_git.bb
+++ b/meta/recipes-support/bmaptool/bmaptool_git.bb
@@ -28,4 +28,9 @@  RDEPENDS:${PN} = "python3-core python3-compression python3-misc python3-mmap pyt
 
 inherit setuptools3
 
+# For compatibility with layers before scarthgap
+RPROVIDES:${PN} = "bmap-tools"
+RREPLACES:${PN} = "bmap-tools"
+RCONFLICTS:${PN} = "bmap-tools"
+
 BBCLASSEXTEND = "native nativesdk"