diff mbox series

openssh: Add a workaround for ICE on powerpc64le

Message ID 20240306195645.2807044-1-William.Lyu@windriver.com
State Accepted, archived
Commit bc793fa9d1fe24c102d91e97b7002b6e637cbfa5
Headers show
Series openssh: Add a workaround for ICE on powerpc64le | expand

Commit Message

Lyu, William March 6, 2024, 7:56 p.m. UTC
From: William Lyu <William.Lyu@windriver.com>

Fixes [YOCTO #15415]

The new openssh version has an ICE on powerpc64le similar to the one on
mips/mips64[1]. By adding flag "--without-hardening" to "./configure",
compiler option "-fzero-call-used-regs" will be removed when compiling. This
prevents certain functions from triggering the following ICE:

unimplemented: argument 'used' is not supported for '-fzero-call-used-regs' on this target

References
[1] https://git.openembedded.org/openembedded-core/commit/?id=5b290566519a87c563945a033cb49863317ad63d

Signed-off-by: William Lyu <William.Lyu@windriver.com>
---
 meta/recipes-connectivity/openssh/openssh_9.6p1.bb | 3 +++
 1 file changed, 3 insertions(+)
diff mbox series

Patch

diff --git a/meta/recipes-connectivity/openssh/openssh_9.6p1.bb b/meta/recipes-connectivity/openssh/openssh_9.6p1.bb
index 1fd36a266f..edd8e8c2d1 100644
--- a/meta/recipes-connectivity/openssh/openssh_9.6p1.bb
+++ b/meta/recipes-connectivity/openssh/openssh_9.6p1.bb
@@ -85,6 +85,9 @@  EXTRA_OECONF:append:libc-musl = " --disable-wtmp --disable-lastlog"
 EXTRA_OECONF:append:mips = " --without-hardening"
 EXTRA_OECONF:append:mips64 = " --without-hardening"
 
+# Work around ICE on powerpc64le starting in 9.6p1
+EXTRA_OECONF:append:powerpc64le = " --without-hardening"
+
 # Since we do not depend on libbsd, we do not want configure to use it
 # just because it finds libutil.h.  But, specifying --disable-libutil
 # causes compile errors, so...