diff mbox series

core-image-full-cmdline: add package-management

Message ID 20240229150304.3643093-1-michael.opdenacker@bootlin.com
State Accepted, archived
Commit 6f06e18adbea74340415807842cac443e3bf37da
Headers show
Series core-image-full-cmdline: add package-management | expand

Commit Message

Michael Opdenacker Feb. 29, 2024, 3:03 p.m. UTC
From: Michael Opdenacker <michael.opdenacker@bootlin.com>

Add "package-management" image feature to the core-image-full-cmdline image,
to support package upgrade testing.

Signed-off-by: Michael Opdenacker <michael.opdenacker@bootlin.com>
Suggested-by: Richard Purdie <richard.purdie@linuxfoundation.org>
---
 meta/recipes-extended/images/core-image-full-cmdline.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Mark Hatle Feb. 29, 2024, 7:29 p.m. UTC | #1
There are plenty of systems where we don't want package-management enabled by 
default.  This will just make core-image-full-cmdline less useful there.

In the past, it's always been up to the user to enable full package-management 
in their configuration, default has been to not have it present.  Has this changed?

On 2/29/24 9:03 AM, Michael Opdenacker via lists.openembedded.org wrote:
> From: Michael Opdenacker <michael.opdenacker@bootlin.com>
> 
> Add "package-management" image feature to the core-image-full-cmdline image,
> to support package upgrade testing.
> 
> Signed-off-by: Michael Opdenacker <michael.opdenacker@bootlin.com>
> Suggested-by: Richard Purdie <richard.purdie@linuxfoundation.org>
> ---
>   meta/recipes-extended/images/core-image-full-cmdline.bb | 2 +-
>   1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/meta/recipes-extended/images/core-image-full-cmdline.bb b/meta/recipes-extended/images/core-image-full-cmdline.bb
> index 4e1cf58d55..b034cd0aeb 100644
> --- a/meta/recipes-extended/images/core-image-full-cmdline.bb
> +++ b/meta/recipes-extended/images/core-image-full-cmdline.bb
> @@ -1,7 +1,7 @@
>   SUMMARY = "A console-only image with more full-featured Linux system \
>   functionality installed."
>   
> -IMAGE_FEATURES += "splash ssh-server-openssh"
> +IMAGE_FEATURES += "splash ssh-server-openssh package-management"
>   
>   IMAGE_INSTALL = "\
>       packagegroup-core-boot \
> 
> 
> 
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#196436): https://lists.openembedded.org/g/openembedded-core/message/196436
> Mute This Topic: https://lists.openembedded.org/mt/104644618/3616948
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [mark.hatle@kernel.crashing.org]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Richard Purdie Feb. 29, 2024, 9:16 p.m. UTC | #2
On Thu, 2024-02-29 at 13:29 -0600, Mark Hatle wrote:
> There are plenty of systems where we don't want package-management
> enabled by default.  This will just make core-image-full-cmdline less
> useful there.
> 
> In the past, it's always been up to the user to enable full package-
> management in their configuration, default has been to not have it
> present.  Has this changed?

Of our images, many of them already enable package-management including
core-image-sato (and derivatives like sdk), core-image-x11, core-image-
weston and build-appliance. In that sense, core-image-full-cmdline was
an outlier.

Whilst it does add some dependencies and metadata it doesn't add that
much overall. This big win for this is that it then lets us test image
upgrades with the artefact built as part of the release artefacts.

That testing does make sense with full-cmdline so bringing it slightly
more into line with the other images seemed like the best/easiest
improvement for a big QA win.

Anyone not needing it can easily remove that feature as they would with
the others.

Cheers,

Richard
Richard Purdie Feb. 29, 2024, 9:17 p.m. UTC | #3
On Thu, 2024-02-29 at 16:03 +0100, michael.opdenacker@bootlin.com
wrote:
> From: Michael Opdenacker <michael.opdenacker@bootlin.com>
> 
> Add "package-management" image feature to the core-image-full-cmdline
> image,
> to support package upgrade testing.
> 
> Signed-off-by: Michael Opdenacker <michael.opdenacker@bootlin.com>
> Suggested-by: Richard Purdie <richard.purdie@linuxfoundation.org>
> ---
>  meta/recipes-extended/images/core-image-full-cmdline.bb | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/meta/recipes-extended/images/core-image-full-cmdline.bb
> b/meta/recipes-extended/images/core-image-full-cmdline.bb
> index 4e1cf58d55..b034cd0aeb 100644
> --- a/meta/recipes-extended/images/core-image-full-cmdline.bb
> +++ b/meta/recipes-extended/images/core-image-full-cmdline.bb
> @@ -1,7 +1,7 @@
>  SUMMARY = "A console-only image with more full-featured Linux system
> \
>  functionality installed."
>  
> -IMAGE_FEATURES += "splash ssh-server-openssh"
> +IMAGE_FEATURES += "splash ssh-server-openssh package-management"
>  
>  IMAGE_INSTALL = "\
>      packagegroup-core-boot \

This does break one of the oe-selftests around gplv3 exclusion handling
unfortunately:

https://autobuilder.yoctoproject.org/typhoon/#/builders/79/builds/6471/steps/15/logs/stdio

Cheers,

Richard
diff mbox series

Patch

diff --git a/meta/recipes-extended/images/core-image-full-cmdline.bb b/meta/recipes-extended/images/core-image-full-cmdline.bb
index 4e1cf58d55..b034cd0aeb 100644
--- a/meta/recipes-extended/images/core-image-full-cmdline.bb
+++ b/meta/recipes-extended/images/core-image-full-cmdline.bb
@@ -1,7 +1,7 @@ 
 SUMMARY = "A console-only image with more full-featured Linux system \
 functionality installed."
 
-IMAGE_FEATURES += "splash ssh-server-openssh"
+IMAGE_FEATURES += "splash ssh-server-openssh package-management"
 
 IMAGE_INSTALL = "\
     packagegroup-core-boot \