diff mbox series

rpm: Fix the following error when run nativesdk-rpm in nativesdk environment.

Message ID 20240228074141.1618722-1-leimaohui@fujitsu.com
State Accepted, archived
Commit c9cb2eb2e662e19d68d27f2eec791986715c3abe
Headers show
Series rpm: Fix the following error when run nativesdk-rpm in nativesdk environment. | expand

Commit Message

Maohui Lei (Fujitsu) Feb. 28, 2024, 7:41 a.m. UTC
From: Lei Maohui <leimaohui@fujitsu.com>

  package busybox-inittab-1.36.1-r0.ubinux_x86_64 is intended for a different architecture
  package busybox-udhcpc-1.36.1-r0.core2_64 is intended for a different architecture
  package ldconfig-2.39+git0+312e159626-r0.core2_64 is intended for a different architecture
  ......

CMAKE_INSTALL_SYSCONFDIR is necessary. If not set
CMAKE_INSTALL_SYSCONFDIR, nativesdk-rpm will use the default setting:
/usr/local/oe-sdk-hardcoded-buildpath/sysroots/x86_64-ubinuxsdk-linux/etc to find rpmrc file.

Signed-off-by: Lei Maohui <leimaohui@fujitsu.com>
---
 meta/recipes-devtools/rpm/rpm_4.19.1.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/meta/recipes-devtools/rpm/rpm_4.19.1.bb b/meta/recipes-devtools/rpm/rpm_4.19.1.bb
index 1f8611a29c..a495f7ced2 100644
--- a/meta/recipes-devtools/rpm/rpm_4.19.1.bb
+++ b/meta/recipes-devtools/rpm/rpm_4.19.1.bb
@@ -57,7 +57,7 @@  EXTRA_OECMAKE:append:libc-musl = " -DENABLE_NLS=OFF -DENABLE_OPENMP=OFF"
 # --sysconfdir prevents rpm from attempting to access machine-specific configuration in sysroot/etc; we need to have it in rootfs
 # --localstatedir prevents rpm from writing its database to native sysroot when building images
 EXTRA_OECMAKE:append:class-native = " -DCMAKE_INSTALL_SYSCONFDIR:PATH=/etc -DCMAKE_INSTALL_LOCALSTATEDIR:PATH=/var"
-EXTRA_OECMAKE:append:class-nativesdk = " -DCMAKE_INSTALL_FULL_SYSCONFDIR=/etc"
+EXTRA_OECMAKE:append:class-nativesdk = " -DCMAKE_INSTALL_SYSCONFDIR:PATH=/etc -DCMAKE_INSTALL_FULL_SYSCONFDIR=/etc"
 
 inherit cmake gettext pkgconfig python3targetconfig
 OECMAKE_GENERATOR = "Unix Makefiles"