diff mbox series

[2/2] libexif: improve ptest packaging

Message ID 20240227155145.2679899-2-ross.burton@arm.com
State New
Headers show
Series [1/2] libexif: remove unused version_underscore | expand

Commit Message

Ross Burton Feb. 27, 2024, 3:51 p.m. UTC
From: Ross Burton <ross.burton@arm.com>

The NLS tests don't actually test anything useful and were not being ran
anyway, so don't install them.

Install the test binaries using libtool so that we install the actual
binaries instead of libtool wrapper scripts.  This means that if we also
tell the Makefile to use /bin/sh there's no need to RDEPEND on bash.

Signed-off-by: Ross Burton <ross.burton@arm.com>
---
 meta/recipes-support/libexif/libexif/run-ptest |  2 +-
 meta/recipes-support/libexif/libexif_0.6.24.bb | 14 ++++----------
 2 files changed, 5 insertions(+), 11 deletions(-)

Comments

Richard Purdie Feb. 28, 2024, 7:12 a.m. UTC | #1
On Tue, 2024-02-27 at 15:51 +0000, Ross Burton wrote:
> From: Ross Burton <ross.burton@arm.com>
> 
> The NLS tests don't actually test anything useful and were not being ran
> anyway, so don't install them.
> 
> Install the test binaries using libtool so that we install the actual
> binaries instead of libtool wrapper scripts.  This means that if we also
> tell the Makefile to use /bin/sh there's no need to RDEPEND on bash.
> 
> Signed-off-by: Ross Burton <ross.burton@arm.com>
> ---
>  meta/recipes-support/libexif/libexif/run-ptest |  2 +-
>  meta/recipes-support/libexif/libexif_0.6.24.bb | 14 ++++----------
>  2 files changed, 5 insertions(+), 11 deletions(-)

https://autobuilder.yoctoproject.org/typhoon/#/builders/83/builds/6617

Lots of QA errors/warnings from this :(

Cheers,

Richard
diff mbox series

Patch

diff --git a/meta/recipes-support/libexif/libexif/run-ptest b/meta/recipes-support/libexif/libexif/run-ptest
index 2d23159eb03..9713a1bec2d 100644
--- a/meta/recipes-support/libexif/libexif/run-ptest
+++ b/meta/recipes-support/libexif/libexif/run-ptest
@@ -1,3 +1,3 @@ 
 #!/bin/sh
 
-make -o Makefile runtest-TESTS
+make -o Makefile SHELL=/bin/sh runtest-TESTS
diff --git a/meta/recipes-support/libexif/libexif_0.6.24.bb b/meta/recipes-support/libexif/libexif_0.6.24.bb
index b407ee52de0..69c91773097 100644
--- a/meta/recipes-support/libexif/libexif_0.6.24.bb
+++ b/meta/recipes-support/libexif/libexif_0.6.24.bb
@@ -23,18 +23,12 @@  do_compile_ptest() {
 }
 
 do_install_ptest() {
-    install ${B}/test/test*[!\.o] ${D}${PTEST_PATH}
-    for f in ${D}${PTEST_PATH}/test*; do
-        sed -i "s/\(LD_LIBRARY_PATH=\).*\(:\$LD_LIBRARY_PATH\)\"/\1.\2/" $f
-    done
-
     install ${B}/test/Makefile ${D}${PTEST_PATH}
     sed -i -e "/^srcdir/c srcdir = \$\{PWD\}" ${D}${PTEST_PATH}/Makefile
 
-    install -d ${D}${PTEST_PATH}/nls
-    install ${B}/test/nls/*[!\.o] ${D}${PTEST_PATH}/nls
-    install -d ${D}${PTEST_PATH}/.libs
-    install ${B}/test/.libs/* ${D}${PTEST_PATH}/.libs
+    for f in ${B}/test/test*[!\.o]; do
+        libtool --mode=install install $f ${D}${PTEST_PATH}
+    done
 
     install ${S}/test/*.sh ${D}${PTEST_PATH}
 
@@ -42,6 +36,6 @@  do_install_ptest() {
     install ${S}/test/testdata/* ${D}${PTEST_PATH}/testdata
 }
 
-RDEPENDS:${PN}-ptest += "make bash"
+RDEPENDS:${PN}-ptest += "make"
 
 BBCLASSEXTEND = "native nativesdk"